summaryrefslogtreecommitdiff
path: root/dev-python/pyfeyn
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyfeyn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyfeyn')
-rw-r--r--dev-python/pyfeyn/Manifest1
-rw-r--r--dev-python/pyfeyn/files/pyfeyn-0.3.4.patch16
-rw-r--r--dev-python/pyfeyn/metadata.xml14
-rw-r--r--dev-python/pyfeyn/pyfeyn-0.3.4-r1.ebuild23
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pyfeyn/Manifest b/dev-python/pyfeyn/Manifest
new file mode 100644
index 00000000000..7f4aad713d4
--- /dev/null
+++ b/dev-python/pyfeyn/Manifest
@@ -0,0 +1 @@
+DIST pyfeyn-0.3.4.tar.gz 27074 SHA256 6b1d86606b9b61cfc6285aec4a15202f60a819368b3e74fc13a586835f22da6e SHA512 b0ce1939d893df3af060cc64d11c2bb09f22c99b074aefe0e79d820ee4c6b5c64f4e8de8f4c31020b33735627b2dead9a70ea9d3504773417a058ac7a1915db8 WHIRLPOOL 6d303b0c941f7d698d4f8ca4d0286be74291392700eec6d63dbec9d9d0db22f77d790022d49176b0dbbb25bc6b44e4360dcf1a4821cb9806de0baf24dfcbebbf
diff --git a/dev-python/pyfeyn/files/pyfeyn-0.3.4.patch b/dev-python/pyfeyn/files/pyfeyn-0.3.4.patch
new file mode 100644
index 00000000000..0017bdd8166
--- /dev/null
+++ b/dev-python/pyfeyn/files/pyfeyn-0.3.4.patch
@@ -0,0 +1,16 @@
+diff -r -U2 pyfeyn-0.3.4.orig/pyfeyn/lines.py pyfeyn-0.3.4/pyfeyn/lines.py
+--- pyfeyn-0.3.4.orig/pyfeyn/lines.py 2014-03-06 23:12:24.000000000 +0700
++++ pyfeyn-0.3.4/pyfeyn/lines.py 2014-05-14 21:45:49.356935407 +0700
+@@ -117,8 +117,12 @@
+ """Make this line a straight line between start and end."""
+ self.arcthrupoint = None
++ return self
+
+
+ def bend(self, amount):
+ """Bend the line to the right by a given distance."""
++ if amount==0:
++ self.arcthrupoint = None
++ return self
+ middle = self.p1.midpoint(self.p2)
+ nx = (middle.y() - self.p1.y()) / abs(self.p1.distance(middle))
diff --git a/dev-python/pyfeyn/metadata.xml b/dev-python/pyfeyn/metadata.xml
new file mode 100644
index 00000000000..ce523852f6d
--- /dev/null
+++ b/dev-python/pyfeyn/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription>Python package for drawing Feynman diagrams
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyfeyn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyfeyn/pyfeyn-0.3.4-r1.ebuild b/dev-python/pyfeyn/pyfeyn-0.3.4-r1.ebuild
new file mode 100644
index 00000000000..7b4bbab094e
--- /dev/null
+++ b/dev-python/pyfeyn/pyfeyn-0.3.4-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package for drawing Feynman diagrams"
+HOMEPAGE="http://pyfeyn.hepforge.org/ https://pypi.python.org/pypi/pyfeyn/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="latex"
+
+DEPEND=""
+RDEPEND="dev-python/pyx[${PYTHON_USEDEP}]
+ latex? ( dev-texlive/texlive-science )"
+
+PATCHES=( "${FILESDIR}"/${P}.patch )