summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml/pygccxml-1.7.5.ebuild
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-06-12 12:29:59 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-06-12 12:30:20 +0900
commit261bb9fd3ee929a2d3db8d7b00b64d4a2e28aea9 (patch)
tree3e75412a5ca4d15388ab2fbddb2f981a34191ff6 /dev-python/pygccxml/pygccxml-1.7.5.ebuild
parentd342c320f6f9818b7b8e507796c8a02e53001b9f (diff)
downloadgentoo-261bb9fd3ee929a2d3db8d7b00b64d4a2e28aea9.tar.gz
gentoo-261bb9fd3ee929a2d3db8d7b00b64d4a2e28aea9.tar.xz
dev-python/pygccxml: bump to 1.7.5, update to new HOMEPAGE and SRC_URI.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/pygccxml/pygccxml-1.7.5.ebuild')
-rw-r--r--dev-python/pygccxml/pygccxml-1.7.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pygccxml/pygccxml-1.7.5.ebuild b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
new file mode 100644
index 00000000000..bfba0a83b2b
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generate an XML description of a C++ program from GCC's internal representation"
+HOMEPAGE="https://github.com/gccxml/pygccxml"
+SRC_URI="https://github.com/gccxml/pygccxml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-arch/unzip
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-cpp/gccxml-0.6"
+
+python_compile_all() {
+ use doc && emake html man
+}
+
+python_test() {
+ "${PYTHON}" unittests/test_all.py
+}
+
+python_install_all() {
+ if use doc ; then
+ local HTML_DOCS=( docs/_build/html )
+ doman docs/_build/man/${PN}.1
+ fi
+
+ distutils-r1_python_install_all
+}