summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-11 09:05:06 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-11 09:53:17 +0200
commit5704cd60333e1122a5f4d01218fb6fcc40fbdfa7 (patch)
treedaab31de64a7f6b348fe5f1a433f22c12c1f0c78 /dev-python/pygccxml
parent43d48d0e17dcb283ec8dd6bd217338562cd3a4ba (diff)
downloadgentoo-5704cd60333e1122a5f4d01218fb6fcc40fbdfa7.tar.gz
gentoo-5704cd60333e1122a5f4d01218fb6fcc40fbdfa7.tar.xz
dev-python/pygccxml: Drop unncessary die
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/pygccxml-1.0.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pygccxml/pygccxml-1.0.0.ebuild b/dev-python/pygccxml/pygccxml-1.0.0.ebuild
index 2e4cae479cf..0836d5058f5 100644
--- a/dev-python/pygccxml/pygccxml-1.0.0.ebuild
+++ b/dev-python/pygccxml/pygccxml-1.0.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
@@ -16,14 +17,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-DEPEND="doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )
- app-arch/unzip"
+DEPEND="
+ app-arch/unzip
+ doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )"
RDEPEND=">=dev-cpp/gccxml-0.6"
python_compile_all() {
- if use doc; then
- esetup.py doc || die
- fi
+ use doc && esetup.py doc
}
python_test() {