summaryrefslogtreecommitdiff
path: root/dev-python/pygit2/pygit2-0.23.3.ebuild
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-02 11:20:15 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-02 11:20:25 +0100
commit5378110319889a5b66a1bbfe9193cf5b69ad8cb8 (patch)
tree82633d1370c518142042caa64a2a40cc145a9424 /dev-python/pygit2/pygit2-0.23.3.ebuild
parente8757bb6afe2a4a9914323965d64e6ad07b08cf5 (diff)
downloadgentoo-5378110319889a5b66a1bbfe9193cf5b69ad8cb8.tar.gz
gentoo-5378110319889a5b66a1bbfe9193cf5b69ad8cb8.tar.xz
dev-python/pygit2: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygit2/pygit2-0.23.3.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-0.23.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-0.23.3.ebuild b/dev-python/pygit2/pygit2-0.23.3.ebuild
new file mode 100644
index 00000000000..99e426f1d2b
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.23.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}