summaryrefslogtreecommitdiff
path: root/dev-python/pygit2/pygit2-0.24.1.ebuild
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-08 03:11:54 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-08 03:11:54 -0400
commit8979951b6eb23ed6221df460794bcef49e074b74 (patch)
tree7b884f0abb80921391883bdfe8680bdee420aadd /dev-python/pygit2/pygit2-0.24.1.ebuild
parent1173a45fd7fd4b406a70949dd4ccf32115203511 (diff)
downloadgentoo-8979951b6eb23ed6221df460794bcef49e074b74.tar.gz
gentoo-8979951b6eb23ed6221df460794bcef49e074b74.tar.xz
dev-python/pygit2: version bump to 0.24.1
Diffstat (limited to 'dev-python/pygit2/pygit2-0.24.1.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-0.24.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-0.24.1.ebuild b/dev-python/pygit2/pygit2-0.24.1.ebuild
new file mode 100644
index 00000000000..82cc7dd14c9
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.24.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.python.org/pypi/pygit2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}