summaryrefslogtreecommitdiff
path: root/dev-python/pygments
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/pygments
parentd4a1e3bd5d1bce9afd703ba5231c84a3178782fd (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.xz
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/pygments')
-rw-r--r--dev-python/pygments/pygments-2.0.2-r1.ebuild52
-rw-r--r--dev-python/pygments/pygments-2.0.2.ebuild3
2 files changed, 2 insertions, 53 deletions
diff --git a/dev-python/pygments/pygments-2.0.2-r1.ebuild b/dev-python/pygments/pygments-2.0.2-r1.ebuild
deleted file mode 100644
index 33077c71e6c..00000000000
--- a/dev-python/pygments/pygments-2.0.2-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1 bash-completion-r1 vcs-snapshot
-
-MY_PN="Pygments"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Pygments is a syntax highlighting package written in Python"
-HOMEPAGE="http://pygments.org/ https://pypi.python.org/pypi/Pygments"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- virtual/ttf-fonts )"
-# dev-texlive/texlive-latexrecommended
-# Removing / commenting out this dep. I can find no mention of it in tests other than
-# importing pygment's own tex module. If it's there and I missed it just uncomment and re-add
-# Tests pass without it
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- cp -r -l tests "${BUILD_DIR}"/ || die
- # With pypy3 there is 1 error out of 1556 tests when run as is and
- # (SKIP=8, errors=1, failures=1) when run with 2to3; meh
- nosetests -w "${BUILD_DIR}"/tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
- newbashcomp external/pygments.bashcomp pygmentize
-}
diff --git a/dev-python/pygments/pygments-2.0.2.ebuild b/dev-python/pygments/pygments-2.0.2.ebuild
index 59b89d7ea5a..2ea5783ccf3 100644
--- a/dev-python/pygments/pygments-2.0.2.ebuild
+++ b/dev-python/pygments/pygments-2.0.2.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1 bash-completion-r1 vcs-snapshot