summaryrefslogtreecommitdiff
path: root/dev-python/pygsl
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-14 18:47:20 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-14 18:54:21 +0100
commitaf650985872dd12ebd9ece6b3dde175a82312d9d (patch)
treecb337ad3fb5dce7ec5edd99e668d0f7dad4891a8 /dev-python/pygsl
parent389aaee545d8b5d14f237ce861ec528f71931652 (diff)
downloadgentoo-af650985872dd12ebd9ece6b3dde175a82312d9d.tar.gz
gentoo-af650985872dd12ebd9ece6b3dde175a82312d9d.tar.xz
dev-python/pygsl: Set max supported gsl version
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=574704 Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pygsl')
-rw-r--r--dev-python/pygsl/pygsl-0.9.5-r1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/pygsl/pygsl-0.9.5-r1.ebuild b/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
index 08a36b8a9f6..92102d21d45 100644
--- a/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
+++ b/dev-python/pygsl/pygsl-0.9.5-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
@@ -16,7 +17,8 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="examples"
-DEPEND="sci-libs/gsl
+DEPEND="
+ <sci-libs/gsl-2
dev-python/numpy[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
# Testsuite written to be run post install