summaryrefslogtreecommitdiff
path: root/dev-python/pyndex
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyndex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyndex')
-rw-r--r--dev-python/pyndex/Manifest1
-rw-r--r--dev-python/pyndex/metadata.xml11
-rw-r--r--dev-python/pyndex/pyndex-0.3.2a-r1.ebuild31
-rw-r--r--dev-python/pyndex/pyndex-0.3.2a.ebuild27
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/pyndex/Manifest b/dev-python/pyndex/Manifest
new file mode 100644
index 00000000000..2bb8065163b
--- /dev/null
+++ b/dev-python/pyndex/Manifest
@@ -0,0 +1 @@
+DIST Pyndex-0.3.2a.tar.gz 34651 SHA256 032564bb4f90da894d2a634b02c65c581db091ce8fee7320b56d487ad27947fe SHA512 f1ddea8cde1f1517ed1c1319cab442ace3e4c9e2a6a2174aca2f348c915c5db2c9fe4c1543f5b16770cc8364cac930a40bef9bce8f7b76c3b0d88c8639acce75 WHIRLPOOL 7c5aa723e222fcffea189f41f29439affbfa66ce2f2326cc87cbd1b2ca72bf00fea19b089e7cb09c1b0b876695ba8702f12cb96f10a59b6f3b7b476f9cee7299
diff --git a/dev-python/pyndex/metadata.xml b/dev-python/pyndex/metadata.xml
new file mode 100644
index 00000000000..307309402a1
--- /dev/null
+++ b/dev-python/pyndex/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>lordvan@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pyndex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyndex/pyndex-0.3.2a-r1.ebuild b/dev-python/pyndex/pyndex-0.3.2a-r1.ebuild
new file mode 100644
index 00000000000..2933a1ae48a
--- /dev/null
+++ b/dev-python/pyndex/pyndex-0.3.2a-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+MY_PN="Pyndex"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple and fast Python full-text indexer (aka search engine) using Metakit as its back-end"
+HOMEPAGE="http://www.divmod.org/Pyndex/index.html"
+SRC_URI="mirror://sourceforge/pyndex/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/metakit-2.4.9.2[python]"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
diff --git a/dev-python/pyndex/pyndex-0.3.2a.ebuild b/dev-python/pyndex/pyndex-0.3.2a.ebuild
new file mode 100644
index 00000000000..818eeaf6255
--- /dev/null
+++ b/dev-python/pyndex/pyndex-0.3.2a.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="Pyndex"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple and fast Python full-text indexer (aka search engine) using Metakit as its back-end"
+HOMEPAGE="http://www.divmod.org/Pyndex/index.html"
+SRC_URI="mirror://sourceforge/pyndex/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND=">=dev-db/metakit-2.4.9.2[python]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"