summaryrefslogtreecommitdiff
path: root/dev-python/pyparsing
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyparsing
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyparsing')
-rw-r--r--dev-python/pyparsing/Manifest3
-rw-r--r--dev-python/pyparsing/metadata.xml15
-rw-r--r--dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild51
-rw-r--r--dev-python/pyparsing/pyparsing-1.5.6.ebuild41
-rw-r--r--dev-python/pyparsing/pyparsing-2.0.1.ebuild29
-rw-r--r--dev-python/pyparsing/pyparsing-2.0.3.ebuild29
6 files changed, 168 insertions, 0 deletions
diff --git a/dev-python/pyparsing/Manifest b/dev-python/pyparsing/Manifest
new file mode 100644
index 00000000000..9cb18a43461
--- /dev/null
+++ b/dev-python/pyparsing/Manifest
@@ -0,0 +1,3 @@
+DIST pyparsing-1.5.6.tar.gz 1418892 SHA256 5c84aa4500e82d5aa2c0842d5628c5da985e68ac1fb33554e0e5547eb3c85a75 SHA512 614c1a016d121b7c4ecf90a164bbe323affd6cf72319c8494e9a583078ffa233c351627fc3e793307e407e043570f8301f112c4d86645dcd130220ed976289c8 WHIRLPOOL 278d37581a950a570ac3cca2a5f8b674c909220fddc47072d9d52c38b8dfc30b335530dffd3c522cd18e58e9bddcc5e48d9184cdaf4b09203bbba308607e24a4
+DIST pyparsing-2.0.1.tar.gz 1129563 SHA256 0007cd3f008eba4a203f1f6b4b133ddc352552c8808b694c88c23db56416e4e4 SHA512 e9c9307c59c7020f4a454458703bd1eb4ef0ac513b2a6a07706b5d676c010f33a72d03d78a61bf3daa96d6598b966a3e4921a88c50f71939a697fa00377ac67a WHIRLPOOL c95815cc6d8471e1ea730daf19ea954fbbddbc67b771700100b04c7103e1ec5e7226e3881a037476f898a3874c072baed7ed159ca32566bd8ed825ab8f4f3cbe
+DIST pyparsing-2.0.3.tar.gz 1462653 SHA256 06e729e1cbf5274703b1f47b6135ed8335999d547f9d8cf048b210fb8ebf844f SHA512 9771851f4b0191c7d3f8d2a2a6d2a9198b173120d3f133d08284b71e792fc59a906d571edea8f44ba04ab00c1d906e1974d1e8a2d6155d492de1358ba99c575a WHIRLPOOL 42b9c7aa0b8d4d91436a01a60cbca64a9c8f7798b7aeb60bd2c4af085f9e13167a5ac5132d55bd890b4890c00428e908dfae32ed78ec153c868ee02ed3cdaa3f
diff --git a/dev-python/pyparsing/metadata.xml b/dev-python/pyparsing/metadata.xml
new file mode 100644
index 00000000000..cbe760bfb74
--- /dev/null
+++ b/dev-python/pyparsing/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ The pyparsing module is an alternative approach to creating and
+ executing simple grammars, vs. the traditional lex/yacc approach, or the
+ use of regular expressions. The pyparsing module provides a library of
+ classes that client code uses to construct the grammar directly in
+ Python code.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pyparsing</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild b/dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild
new file mode 100644
index 00000000000..efe8e7f3d23
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-1.5.6-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+# Build system copies the module from py2/py3 version to the regular
+# name before installing.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # resorted to sed, fixed in June upstream, bug ID: 3381439.
+ # See Bug #443836.
+ sed -e "s/26 June 2011 10:53/16 June 2012 03:08/" \
+ -e 's:exc.__traceback__:pe.__traceback__:' \
+ -i pyparsing_py3.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ local HTML_DOCS=( HowToUsePyparsing.html )
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/doc/${PF}
+
+ if use doc; then
+ dohtml -r htmldoc/*
+ doins docs/*.pdf
+ fi
+
+ if use examples; then
+ doins -r examples
+ fi
+}
diff --git a/dev-python/pyparsing/pyparsing-1.5.6.ebuild b/dev-python/pyparsing/pyparsing-1.5.6.ebuild
new file mode 100644
index 00000000000..604c388b6a0
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-1.5.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+PYTHON_MODNAME="pyparsing.py"
+
+src_install() {
+ distutils_src_install
+
+ dohtml HowToUsePyparsing.html
+ dodoc CHANGES
+
+ if use doc; then
+ dohtml -r htmldoc/*
+ insinto /usr/share/doc/${PF}
+ doins docs/*.pdf
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/pyparsing/pyparsing-2.0.1.ebuild b/dev-python/pyparsing/pyparsing-2.0.1.ebuild
new file mode 100644
index 00000000000..7148e7e1b77
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND="!dev-python/pyparsing:py2 !dev-python/pyparsing:py3"
+
+python_install_all() {
+ local HTML_DOCS=( HowToUsePyparsing.html )
+ use doc && HTML_DOCS+=( htmldoc/ )
+
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.pdf
+ use examples && dodoc -r examples
+}
diff --git a/dev-python/pyparsing/pyparsing-2.0.3.ebuild b/dev-python/pyparsing/pyparsing-2.0.3.ebuild
new file mode 100644
index 00000000000..2845373889f
--- /dev/null
+++ b/dev-python/pyparsing/pyparsing-2.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="pyparsing is an easy-to-use Python module for text parsing"
+HOMEPAGE="http://pyparsing.wikispaces.com/ http://pypi.python.org/pypi/pyparsing"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND="!dev-python/pyparsing:py2 !dev-python/pyparsing:py3"
+
+python_install_all() {
+ local HTML_DOCS=( HowToUsePyparsing.html )
+ if use doc; then
+ HTML_DOCS+=( htmldoc/. )
+ dodoc docs/*.pdf
+ fi
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}