summaryrefslogtreecommitdiff
path: root/dev-python/pyphen
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyphen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyphen')
-rw-r--r--dev-python/pyphen/Manifest2
-rw-r--r--dev-python/pyphen/metadata.xml9
-rw-r--r--dev-python/pyphen/pyphen-0.8.ebuild24
-rw-r--r--dev-python/pyphen/pyphen-0.9.1.ebuild24
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
new file mode 100644
index 00000000000..da7e32c72ea
--- /dev/null
+++ b/dev-python/pyphen/Manifest
@@ -0,0 +1,2 @@
+DIST Pyphen-0.8.tar.gz 962586 SHA256 378169ce89b8d3b6a0b95bbfdedc9da8c428d6b7c98ff6498ff41c390702a21a SHA512 230ae11fa3aabba52c923a562284cbc9051c42aa8bc6336bf7e66a47db8974adb3fe136f605bac4cb8c5dee20e68181e6fb3b0c5726a35ab85d11ac5e30c537a WHIRLPOOL 6a7ce38c2d0ca801d58464de8d2c184b28762ecb7b469494675ae87384bbf76cd333d4e3c7aeb32c75cc37c40d5169bb8dd833e3d979e421475ebd6ec5dc8092
+DIST Pyphen-0.9.1.tar.gz 1020062 SHA256 f518012a3296689b13f80a879ed75d1f876e6d9c09f982b114e78847407aa515 SHA512 b3fd71aab1a85d7a8a482907f5bffec1179a29ec3cbeef02a59d8ec975b57d3d667b47c7014b27ee08edeef5d652fcc2d091062e67e4ff2897cd37bcd93ad174 WHIRLPOOL e68bbf476880fd7c40d7b762e684835b51396a6c005d310faef51da6fe89df3c8fb1d98c5897de102248232ec0152c1a2687ff941c9f3391df646c2439195e1b
diff --git a/dev-python/pyphen/metadata.xml b/dev-python/pyphen/metadata.xml
new file mode 100644
index 00000000000..9b0f6f22e9a
--- /dev/null
+++ b/dev-python/pyphen/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Pyphen</remote-id>
+ <remote-id type="github">Kozea/Pyphen</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyphen/pyphen-0.8.ebuild b/dev-python/pyphen/pyphen-0.8.ebuild
new file mode 100644
index 00000000000..31fe2cc350b
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.8.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+MY_PN="Pyphen"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-python/pyphen/pyphen-0.9.1.ebuild b/dev-python/pyphen/pyphen-0.9.1.ebuild
new file mode 100644
index 00000000000..d8d4f9661d1
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.9.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+MY_PN="Pyphen"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"