summaryrefslogtreecommitdiff
path: root/dev-python/pypy
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-11-12 16:05:18 +0100
committerMichał Górny <mgorny@gentoo.org>2015-11-12 17:03:16 +0100
commit1220629606e4287bc60274825ccb9ab3f9db76f1 (patch)
tree796118ff88dc811231f76828a1b77efb8f87f343 /dev-python/pypy
parentbc46e49ff67cf1e5157ab95b41e780067f433685 (diff)
downloadgentoo-1220629606e4287bc60274825ccb9ab3f9db76f1.tar.gz
gentoo-1220629606e4287bc60274825ccb9ab3f9db76f1.tar.xz
dev-python/pypy*: Fix epython.py module first install
Diffstat (limited to 'dev-python/pypy')
-rw-r--r--dev-python/pypy/pypy-2.4.0.ebuild9
-rw-r--r--dev-python/pypy/pypy-2.5.1.ebuild9
-rw-r--r--dev-python/pypy/pypy-2.6.0.ebuild9
-rw-r--r--dev-python/pypy/pypy-4.0.0.ebuild9
4 files changed, 24 insertions, 12 deletions
diff --git a/dev-python/pypy/pypy-2.4.0.ebuild b/dev-python/pypy/pypy-2.4.0.ebuild
index 21af59eba0d..9442c709f36 100644
--- a/dev-python/pypy/pypy-2.4.0.ebuild
+++ b/dev-python/pypy/pypy-2.4.0.ebuild
@@ -194,11 +194,14 @@ src_install() {
einfo "Generating caches and byte-compiling ..."
- python_export pypy EPYTHON PYTHON PYTHON_SITEDIR
- local PYTHON=${ED%/}${INSDESTTREE}/pypy-c
+ local -x PYTHON=${ED%/}${INSDESTTREE}/pypy-c
local -x LD_LIBRARY_PATH="${ED%/}${INSDESTTREE}"
+ # we can't use eclass function since PyPy is dumb and always gives
+ # paths relative to the interpreter
+ local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages
+ python_export pypy EPYTHON
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
# Generate Grammar and PatternGrammar pickles.
diff --git a/dev-python/pypy/pypy-2.5.1.ebuild b/dev-python/pypy/pypy-2.5.1.ebuild
index 87af793b5da..d12930ce2cc 100644
--- a/dev-python/pypy/pypy-2.5.1.ebuild
+++ b/dev-python/pypy/pypy-2.5.1.ebuild
@@ -194,11 +194,14 @@ src_install() {
einfo "Generating caches and byte-compiling ..."
- python_export pypy EPYTHON PYTHON PYTHON_SITEDIR
- local PYTHON=${ED%/}${INSDESTTREE}/pypy-c
+ local -x PYTHON=${ED%/}${INSDESTTREE}/pypy-c
local -x LD_LIBRARY_PATH="${ED%/}${INSDESTTREE}"
+ # we can't use eclass function since PyPy is dumb and always gives
+ # paths relative to the interpreter
+ local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages
+ python_export pypy EPYTHON
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
# Generate Grammar and PatternGrammar pickles.
diff --git a/dev-python/pypy/pypy-2.6.0.ebuild b/dev-python/pypy/pypy-2.6.0.ebuild
index 15820ef0dba..779b81c5d63 100644
--- a/dev-python/pypy/pypy-2.6.0.ebuild
+++ b/dev-python/pypy/pypy-2.6.0.ebuild
@@ -200,11 +200,14 @@ src_install() {
einfo "Generating caches and byte-compiling ..."
- python_export pypy EPYTHON PYTHON PYTHON_SITEDIR
- local PYTHON=${ED%/}${INSDESTTREE}/pypy-c
+ local -x PYTHON=${ED%/}${INSDESTTREE}/pypy-c
local -x LD_LIBRARY_PATH="${ED%/}${INSDESTTREE}"
+ # we can't use eclass function since PyPy is dumb and always gives
+ # paths relative to the interpreter
+ local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages
+ python_export pypy EPYTHON
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
# Generate Grammar and PatternGrammar pickles.
diff --git a/dev-python/pypy/pypy-4.0.0.ebuild b/dev-python/pypy/pypy-4.0.0.ebuild
index da155c286ea..0bf61efb04b 100644
--- a/dev-python/pypy/pypy-4.0.0.ebuild
+++ b/dev-python/pypy/pypy-4.0.0.ebuild
@@ -200,11 +200,14 @@ src_install() {
einfo "Generating caches and byte-compiling ..."
- python_export pypy EPYTHON PYTHON PYTHON_SITEDIR
- local PYTHON=${ED%/}${INSDESTTREE}/pypy-c
+ local -x PYTHON=${ED%/}${INSDESTTREE}/pypy-c
local -x LD_LIBRARY_PATH="${ED%/}${INSDESTTREE}"
+ # we can't use eclass function since PyPy is dumb and always gives
+ # paths relative to the interpreter
+ local PYTHON_SITEDIR=${EPREFIX}/usr/$(get_libdir)/pypy/site-packages
+ python_export pypy EPYTHON
- echo "EPYTHON='${EPYTHON}'" > epython.py
+ echo "EPYTHON='${EPYTHON}'" > epython.py || die
python_domodule epython.py
# Generate Grammar and PatternGrammar pickles.