summaryrefslogtreecommitdiff
path: root/dev-python/pysaml2
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/pysaml2
parent150a8c1ca0830ab41b9a33075f8eac102cfe9421 (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.xz
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/pysaml2')
-rw-r--r--dev-python/pysaml2/Manifest1
-rw-r--r--dev-python/pysaml2/pysaml2-4.0.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pysaml2/Manifest b/dev-python/pysaml2/Manifest
index 1468249c2e2..f17591e9825 100644
--- a/dev-python/pysaml2/Manifest
+++ b/dev-python/pysaml2/Manifest
@@ -1 +1,2 @@
DIST pysaml2-3.0.0.tar.gz 13051759 SHA256 22aec520b3324f1f33cad58862f03ec3e000b2abc36880a5202615ba9fda5cc0 SHA512 a16281888e86222204dbabcec1501d3d2ef6374ad63225f60664a663f2aad6dd2ffe9d8e77f7f1fc18fefc12a4ba44d183ed04c201774ad9e174fd604b91bb78 WHIRLPOOL 7814d31852144c6bf9de8581e7cbc1d7d11bb337d53b828022a5a956615acdd1f3ad4ee79dbb8632a0a80c17dc6119ea31f54734ed5afd254f77eb05ea2ab63d
+DIST pysaml2-4.0.2.tar.gz 13657558 SHA256 24cec8dbc20a7772854563ffc9a19297afcc38c4c7558c063b4c8c302f8a958b SHA512 debe23c2b193ca9f937bdb4fc9e8f308fa012c18e50e40183f7e531434af52b6e4d36608be3e9b0321190930cdfd9eb24555ed1805083e32db8de0f57e5afb14 WHIRLPOOL 303217ea7408986435a31ac97deae3d2b14393674d360d30cbdacf1c673d265b21505af1dea8c536c4698dc6861058f6e57421aaa5bb411daa68d5d02c1ba2c2
diff --git a/dev-python/pysaml2/pysaml2-4.0.2.ebuild b/dev-python/pysaml2/pysaml2-4.0.2.ebuild
new file mode 100644
index 00000000000..cda3b112956
--- /dev/null
+++ b/dev-python/pysaml2/pysaml2-4.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of SAML Version 2 to be used in a WSGI environment"
+HOMEPAGE="https://github.com/rohe/pysaml2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/repoze-who[${PYTHON_USEDEP}]
+ >=dev-python/pycrypto-2.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"