summaryrefslogtreecommitdiff
path: root/dev-python/pyshark
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyshark
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyshark')
-rw-r--r--dev-python/pyshark/Manifest3
-rw-r--r--dev-python/pyshark/metadata.xml9
-rw-r--r--dev-python/pyshark/pyshark-0.3.4.ebuild28
-rw-r--r--dev-python/pyshark/pyshark-0.3.5.ebuild28
-rw-r--r--dev-python/pyshark/pyshark-0.3.6.ebuild28
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/pyshark/Manifest b/dev-python/pyshark/Manifest
new file mode 100644
index 00000000000..1475822a47b
--- /dev/null
+++ b/dev-python/pyshark/Manifest
@@ -0,0 +1,3 @@
+DIST pyshark-0.3.4.zip 22495 SHA256 d9f9e4230c4dce9a3ae4fd133a6467c86816751de7b2c6859836eeb0bcd1c480 SHA512 9a9bc78422741ee1c483eb6ceb6717e660d80b0489286da497cd58f68328d6ea60acbb54fb8900f9f2dc1fa3fbfd8d663e7772b934eaf62fdd89b6115273421d WHIRLPOOL 5bece1406ef1978b14a47e2d40169dfa47ac5f929ad425da343077b1c000538507f5390331c2b9800d9ac997fbdce6863c6a61f0cc1e4b963412f3109020fe0a
+DIST pyshark-0.3.5.zip 23561 SHA256 6b6e3d9af2e40e97bedaae6c9cadecf3006be432923f25d25ba9705813ee5753 SHA512 0079e07a9a593de98b44564e860d79fd7b35c50f37ef3d616a56afec5273b864c22c8ed6126f3ad6c533cae90ea60e876b29ea9873656d3c7bfc13c2a2b47612 WHIRLPOOL b5d2a66382036f6f3a5ab4f7025fedc0ed7b1513792469d8e63d322a31ddec9527be3944d863dcdac4115b2e90bf1fa518d17bdbedf745f8b59cabfd98979f69
+DIST pyshark-0.3.6.tar.gz 15237 SHA256 51372c0a36446af45f0101d4fc97b336a096356c28da6626041889bf3b24c6f2 SHA512 e2250af229f072f32fa7900dbafbc29b5964134dd7849b53729afb220a5a20faa3b48515d1b83f0084a6f251187b00c192ce5b16e276faf784404bfe5b9c1fa5 WHIRLPOOL 0e77ac977818e61386ac47a64bb31da138c5a2736768a7806d638745c547bf58b777060cc1958af9af40a28ebf20e89f67b4cf292588ebd5b3aec5f30fe10e26
diff --git a/dev-python/pyshark/metadata.xml b/dev-python/pyshark/metadata.xml
new file mode 100644
index 00000000000..f9b3553b83b
--- /dev/null
+++ b/dev-python/pyshark/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyshark</remote-id>
+ <remote-id type="github">KimiNewt/pyshark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyshark/pyshark-0.3.4.ebuild b/dev-python/pyshark/pyshark-0.3.4.ebuild
new file mode 100644
index 00000000000..91aa2b83c6e
--- /dev/null
+++ b/dev-python/pyshark/pyshark-0.3.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python wrapper for tshark output parsing"
+HOMEPAGE="https://pypi.python.org/pypi/pyshark https://github.com/KimiNewt/pyshark"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/futures[${PYTHON_USEDEP}]
+ dev-python/logbook[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/trollius[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ net-analyzer/wireshark"
+
+DOCS=( README.txt )
diff --git a/dev-python/pyshark/pyshark-0.3.5.ebuild b/dev-python/pyshark/pyshark-0.3.5.ebuild
new file mode 100644
index 00000000000..75d56c41915
--- /dev/null
+++ b/dev-python/pyshark/pyshark-0.3.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python wrapper for tshark output parsing"
+HOMEPAGE="https://pypi.python.org/pypi/pyshark https://github.com/KimiNewt/pyshark"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# See pyshark.egg-info/requires.txt
+RDEPEND="dev-python/py[${PYTHON_USEDEP}]
+ dev-python/logbook[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/trollius[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ net-analyzer/wireshark"
+# Tests exlcuded in MANIFEST.in
diff --git a/dev-python/pyshark/pyshark-0.3.6.ebuild b/dev-python/pyshark/pyshark-0.3.6.ebuild
new file mode 100644
index 00000000000..752b5295a71
--- /dev/null
+++ b/dev-python/pyshark/pyshark-0.3.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python wrapper for tshark output parsing"
+HOMEPAGE="https://pypi.python.org/pypi/pyshark https://github.com/KimiNewt/pyshark"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# See pyshark.egg-info/requires.txt
+RDEPEND="dev-python/py[${PYTHON_USEDEP}]
+ dev-python/logbook[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/trollius[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ net-analyzer/wireshark"
+# Tests exlcuded in MANIFEST.in