summaryrefslogtreecommitdiff
path: root/dev-python/pysrt
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-23 18:38:12 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-24 21:31:36 +0800
commitb48e417c0240f93e19d65239829d639425b80e1a (patch)
treeb908ee6c16ef6c9b94ba78e551275330bfc5e3ab /dev-python/pysrt
parent4e0e8e40c822d9240e93054eb164b54ac02696f3 (diff)
downloadgentoo-b48e417c0240f93e19d65239829d639425b80e1a.tar.gz
gentoo-b48e417c0240f93e19d65239829d639425b80e1a.tar.xz
dev-python/pysrt: bump to 1.1.1
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1331 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/pysrt')
-rw-r--r--dev-python/pysrt/Manifest1
-rw-r--r--dev-python/pysrt/metadata.xml1
-rw-r--r--dev-python/pysrt/pysrt-1.1.1.ebuild31
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pysrt/Manifest b/dev-python/pysrt/Manifest
index 99bff7ed598..e993f6c6c52 100644
--- a/dev-python/pysrt/Manifest
+++ b/dev-python/pysrt/Manifest
@@ -1,2 +1,3 @@
DIST pysrt-1.0.1.tar.gz 11741 SHA256 5300a1584c8d15a1c49ef8880fa1ef7a4274ce3f24dde83ad581d12d875f6784 SHA512 cd03d40ebef953d7ea67073a114f10a87eb142670ece727d09a31b498835d8485ac0c125f4281b6ababdd6f0757f9549ce38cb05eda79b23ff17950ab891d0eb WHIRLPOOL f7629430ac7ee9b2a69d5618346e2f97f01a68683e8b9ef8c13519a87a7043852c142ba050b338ddccc992c4ada01bbae41b9d2bab2696cdb0fdc50761d7dd81
DIST pysrt-1.1.0.tar.gz 12171 SHA256 7f5468b15b05341e7b6086b611a326588da8dd7f649b1482cbb63cce7ff88af6 SHA512 31d085ca255cc9a09fe0df8611067ad39db36789b9cce89638382b2bcd5c4cad93a4cf1b19d852eb5a954fff89e602ab6359d4846ba9c6ca05d4b7a3b27ffa24 WHIRLPOOL 535f8f46b801efc1a4addda196a05135e6bda26360c51f7a62f902047017a3458970c4fd8cf6b51cdb0a20bede69e96d9d175bb97ba9dfbefd5ea9351249c409
+DIST pysrt-1.1.1.tar.gz 104027 SHA256 fb4c10424549fc5a32d19cd5091f00316b875461fcd79a7809bb55056974d0aa SHA512 607f80c1f66702d36b6fa54b293f59c6a28415d812bf54d7210075d1c84a7547ce2776c0809910ed3d79c08a3c595ce74719976d8f2818820a3f4a306ffc1825 WHIRLPOOL 9f3e4e76286ad5f2b90bd81eee3165e29295372b2f3c112875ea7c90fa57c04c8985a94b1106ba886a5ed81a6200a938a94c634ef0b5d92c85793b7e36d9fa6f
diff --git a/dev-python/pysrt/metadata.xml b/dev-python/pysrt/metadata.xml
index 9950bf88aff..9cc7c5e2732 100644
--- a/dev-python/pysrt/metadata.xml
+++ b/dev-python/pysrt/metadata.xml
@@ -13,5 +13,6 @@
<upstream>
<remote-id type="pypi">pysrt</remote-id>
<remote-id type="github">byroot/pysrt</remote-id>
+ <bugs-to>https://github.com/byroot/pysrt/issues</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pysrt/pysrt-1.1.1.ebuild b/dev-python/pysrt/pysrt-1.1.1.ebuild
new file mode 100644
index 00000000000..26bc3bb49ab
--- /dev/null
+++ b/dev-python/pysrt/pysrt-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library used to edit or create SubRip files"
+HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
+SRC_URI="https://pypi.python.org/packages/f6/33/16ad65a8973cb8bcb494af09ee1b9ab5ffdd6ff300bce5d3ac7d3cb1f2cc/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[coverage(+),${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=pysrt \
+ || die "Tests failed under ${EPYTHON}"
+}