summaryrefslogtreecommitdiff
path: root/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-02-26 16:14:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-02-26 18:02:05 +0000
commitf1d4afbf2f8f5ca5c5fdad4d7bd5bc29daea6840 (patch)
treea3cb8a27fed80c9a723ae50cc09a6311d0343d65 /dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
parent2d333956968bc747225c980e443bcd20797d2f1b (diff)
downloadgentoo-f1d4afbf2f8f5ca5c5fdad4d7bd5bc29daea6840.tar.gz
gentoo-f1d4afbf2f8f5ca5c5fdad4d7bd5bc29daea6840.tar.xz
dev-python/pytest-arraydiff: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild')
-rw-r--r--dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
new file mode 100644
index 00000000000..6d12ab1feeb
--- /dev/null
+++ b/dev-python/pytest-arraydiff/pytest-arraydiff-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DOCS=( README.rst CHANGES.md )
+
+DESCRIPTION="pytest plugin to facilitate comparison of arrays"
+HOMEPAGE="https://github.com/astrofrog/pytest-arraydiff/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"