summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-09 12:16:52 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-09 12:49:41 +0100
commit98c9cbc46b8f0275b8381516a706cced883044c4 (patch)
tree944ddb7bb218efb720cf2cc32dd1eb9cf7cafe7e /dev-python/pytest-cov
parenta9939bdc42d1397d5f70473b0c053e65aa533369 (diff)
downloadgentoo-98c9cbc46b8f0275b8381516a706cced883044c4.tar.gz
gentoo-98c9cbc46b8f0275b8381516a706cced883044c4.tar.xz
dev-python/pytest-cov: Add tests
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.2.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/pytest-cov/pytest-cov-2.2.0.ebuild b/dev-python/pytest-cov/pytest-cov-2.2.0.ebuild
index be7bf3ce01b..a6fa5563846 100644
--- a/dev-python/pytest-cov/pytest-cov-2.2.0.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-2.2.0.ebuild
@@ -26,12 +26,19 @@ DEPEND="
test? (
dev-python/virtualenv[${PYTHON_USEDEP}]
dev-python/process-tests[${PYTHON_USEDEP}]
- dev-python/pytest-cache[${PYTHON_USEDEP}]
+ || (
+ >=dev-python/pytest-2.8.0[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ )
dev-python/pytest-xdist[${PYTHON_USEDEP}]
dev-python/pytest-capturelog[${PYTHON_USEDEP}]
)"
+# https://github.com/pytest-dev/pytest-cov/issues/99
+RESTRICT=test
+
python_test() {
PYTHONPATH="${S}/tests:${BUILD_DIR}/lib" \
- py.test -p pytest_cov -vvx || die
+ PYTEST_PLUGINS=pytest_cov \
+ py.test -v -v -x || die
}