summaryrefslogtreecommitdiff
path: root/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-01 15:52:39 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-01 16:56:21 +0200
commitb79a44c86e275d9ebef960ed9fb962950a3ce048 (patch)
tree013aaea2a4f36218e16a586b20ebfd034cf66a2f /dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
parent6f3f790c1a15566328d38ccf182f00316f512184 (diff)
downloadgentoo-b79a44c86e275d9ebef960ed9fb962950a3ce048.tar.gz
gentoo-b79a44c86e275d9ebef960ed9fb962950a3ce048.tar.xz
dev-python/pytest-subtesthack: New package, needed for vdirsyncer tests
Diffstat (limited to 'dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild')
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
new file mode 100644
index 00000000000..5213ff6241f
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
+# pypi tarball misses tests
+SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}