summaryrefslogtreecommitdiff
path: root/dev-python/python-cinderclient/python-cinderclient-1.6.0.ebuild
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:21:17 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 16:21:17 -0500
commit2c93699802dfa5bd47ad71a9f6d5c0e5eea0c6ec (patch)
tree7fb3daefe2eafbc28f01cfe102b47730067a513c /dev-python/python-cinderclient/python-cinderclient-1.6.0.ebuild
parente77865da21ac6ce79d34874b360b462b3d4c7947 (diff)
downloadgentoo-2c93699802dfa5bd47ad71a9f6d5c0e5eea0c6ec.tar.gz
gentoo-2c93699802dfa5bd47ad71a9f6d5c0e5eea0c6ec.tar.xz
dev-python/python-cinderclient: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/python-cinderclient/python-cinderclient-1.6.0.ebuild')
-rw-r--r--dev-python/python-cinderclient/python-cinderclient-1.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-cinderclient/python-cinderclient-1.6.0.ebuild b/dev-python/python-cinderclient/python-cinderclient-1.6.0.ebuild
new file mode 100644
index 00000000000..234be30a626
--- /dev/null
+++ b/dev-python/python-cinderclient/python-cinderclient-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Cinder API"
+HOMEPAGE="https://launchpad.net/python-cinderclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/python-keystoneclient-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i '/^argparse/d' requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}