summaryrefslogtreecommitdiff
path: root/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-09-28 10:19:10 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-09-28 10:19:35 -0700
commitc9050c99d18c223561dbedddc4d747bef899508b (patch)
treea3e6d0e378496a4f4fd4321a420e306fe6beedde /dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
parent1dd1f543769393cbf47f92d75c744d50d16efd08 (diff)
downloadgentoo-c9050c99d18c223561dbedddc4d747bef899508b.tar.gz
gentoo-c9050c99d18c223561dbedddc4d747bef899508b.tar.xz
dev-python/python-ebtables: New package, python bindings for ebtables
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'dev-python/python-ebtables/python-ebtables-0.2.0.ebuild')
-rw-r--r--dev-python/python-ebtables/python-ebtables-0.2.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild b/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
new file mode 100644
index 00000000000..d8bec59d8cf
--- /dev/null
+++ b/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ebtables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="https://github.com/ldx/${PN}/archive/v0.2.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-firewall/ebtables[-static]
+ dev-python/cffi[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"