summaryrefslogtreecommitdiff
path: root/dev-python/python-gnupg
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-gnupg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-gnupg')
-rw-r--r--dev-python/python-gnupg/Manifest1
-rw-r--r--dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch20
-rw-r--r--dev-python/python-gnupg/files/python-gnupg-0.3.7-msg-handle.patch31
-rw-r--r--dev-python/python-gnupg/metadata.xml9
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.3.7.ebuild26
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/Manifest b/dev-python/python-gnupg/Manifest
new file mode 100644
index 00000000000..4d6eeaf2d44
--- /dev/null
+++ b/dev-python/python-gnupg/Manifest
@@ -0,0 +1 @@
+DIST python-gnupg-0.3.7.tar.gz 48728 SHA256 2bf59ff55c036e49d5da12d370447679f14d242567df4c2c0fc61b4601ca0d59 SHA512 6166cef11307dd4782000ab7263778436998a816a45e4471fcbe244b123703bf9ded5bc6ef5cd47ed0c561ef42660980576edf57c62029bb0326642b7c538dd3 WHIRLPOOL 93770439486689dfcaf296d158c3978a71c72d32ba9f0e5b4ec4c97dfda16177ee5e06f0b616112cdfb9cd96c3a93700a0d4302116401c6146f3cd7437b7e29b
diff --git a/dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch b/dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch
new file mode 100644
index 00000000000..66512ab0816
--- /dev/null
+++ b/dev-python/python-gnupg/files/python-gnupg-0.3.6-skip-search-keys-tests.patch
@@ -0,0 +1,20 @@
+--- python-gnupg-0.3.6/gnupg.py
++++ python-gnupg-0.3.6/gnupg.py
+@@ -1078,6 +1078,7 @@
+ def search_keys(self, query, keyserver='pgp.mit.edu'):
+ """ search keyserver by query (using --search-keys option)
+
++ # doctest: +SKIP
+ >>> import shutil
+ >>> shutil.rmtree('keys')
+ >>> gpg = GPG(gnupghome='keys')
+--- python-gnupg-0.3.6/test_gnupg.py
++++ python-gnupg-0.3.6/test_gnupg.py
+@@ -493,6 +493,7 @@
+ os.remove(fn)
+ logger.debug("test_file_encryption_and_decryption ends")
+
++ @unittest.skip("requires network access")
+ def test_search_keys(self):
+ "Test that searching for keys works"
+ r = self.gpg.search_keys('<vinay_sajip@hotmail.com>')
diff --git a/dev-python/python-gnupg/files/python-gnupg-0.3.7-msg-handle.patch b/dev-python/python-gnupg/files/python-gnupg-0.3.7-msg-handle.patch
new file mode 100644
index 00000000000..9f4b6f562ce
--- /dev/null
+++ b/dev-python/python-gnupg/files/python-gnupg-0.3.7-msg-handle.patch
@@ -0,0 +1,31 @@
+https://bitbucket.org/vinay.sajip/python-gnupg/commits/79c73a9ce6e33555246f9dae2ef4be9964e2704b
+# HG changeset patch
+# User Vinay Sajip <vinay_sajip@yahoo.co.uk>
+# Date 1419023737 0
+# Node ID 79c73a9ce6e33555246f9dae2ef4be9964e2704b
+# Parent 767aa49b175738b6d0404a2fb2fca3e3c081e0a8
+Closes #22: handled PROGRESS messages during verification and signing.
+
+diff --git a/gnupg.py b/gnupg.py
+--- a/gnupg.py
++++ b/gnupg.py
+@@ -221,7 +221,8 @@
+ "PLAINTEXT_LENGTH", "POLICY_URL", "DECRYPTION_INFO",
+ "DECRYPTION_OKAY", "INV_SGNR", "FILE_START", "FILE_ERROR",
+ "FILE_DONE", "PKA_TRUST_GOOD", "PKA_TRUST_BAD", "BADMDC",
+- "GOODMDC", "NO_SGNR", "NOTATION_NAME", "NOTATION_DATA"):
++ "GOODMDC", "NO_SGNR", "NOTATION_NAME", "NOTATION_DATA",
++ "PROGRESS"):
+ pass
+ elif key == "BADSIG":
+ self.valid = False
+@@ -601,7 +602,7 @@
+ if key in ("USERID_HINT", "NEED_PASSPHRASE", "BAD_PASSPHRASE",
+ "GOOD_PASSPHRASE", "BEGIN_SIGNING", "CARDCTRL", "INV_SGNR",
+ "NO_SGNR", "MISSING_PASSPHRASE", "NEED_PASSPHRASE_PIN",
+- "SC_OP_FAILURE", "SC_OP_SUCCESS"):
++ "SC_OP_FAILURE", "SC_OP_SUCCESS", "PROGRESS"):
+ pass
+ elif key in ("KEYEXPIRED", "SIGEXPIRED"):
+ self.status = 'key expired'
+
diff --git a/dev-python/python-gnupg/metadata.xml b/dev-python/python-gnupg/metadata.xml
new file mode 100644
index 00000000000..0b22cf585fa
--- /dev/null
+++ b/dev-python/python-gnupg/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="google-code">python-gnupg</remote-id>
+ <remote-id type="github">vsajip/python-gnupg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.7.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.7.ebuild
new file mode 100644
index 00000000000..ef3b341feee
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.3.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="https://github.com/vsajip/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch
+ "${FILESDIR}"/${P}-msg-handle.patch )
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}