summaryrefslogtreecommitdiff
path: root/dev-python/python-mpd/python-mpd-0.5.5.ebuild
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2016-02-20 20:37:09 +0100
committerChristoph Mende <angelos@gentoo.org>2016-02-20 20:38:23 +0100
commit3209e44860235c3bed748a0bff6ca755cc57135e (patch)
tree12c2a79526241d333a32a7d0f5375f1d3dcdfff0 /dev-python/python-mpd/python-mpd-0.5.5.ebuild
parent800e8421483b37938f0d443c22e749de4af3c26d (diff)
downloadgentoo-3209e44860235c3bed748a0bff6ca755cc57135e.tar.gz
gentoo-3209e44860235c3bed748a0bff6ca755cc57135e.tar.xz
dev-python/python-mpd: version bump to 0.5.5
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/python-mpd/python-mpd-0.5.5.ebuild')
-rw-r--r--dev-python/python-mpd/python-mpd-0.5.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-mpd/python-mpd-0.5.5.ebuild b/dev-python/python-mpd/python-mpd-0.5.5.ebuild
new file mode 100644
index 00000000000..343c4ad31ac
--- /dev/null
+++ b/dev-python/python-mpd/python-mpd-0.5.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="https://github.com/Mic92/python-mpd2"
+SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( doc/changes.rst doc/topics/{advanced,commands,getting-started,logging}.rst README.rst )
+
+python_test() {
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}