summaryrefslogtreecommitdiff
path: root/dev-python/python-oembed/python-oembed-0.2.4.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-03-01 19:55:31 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-03-01 20:04:30 +0100
commit31d4c89d5ee52e44554be844bc019094a1feebb1 (patch)
treee5269a7176d17d3b1e0431cec67af9b100a7dbfe /dev-python/python-oembed/python-oembed-0.2.4.ebuild
parent46a59dee7dfa37f123fa85f3333a593ca6bb0465 (diff)
downloadgentoo-31d4c89d5ee52e44554be844bc019094a1feebb1.tar.gz
gentoo-31d4c89d5ee52e44554be844bc019094a1feebb1.tar.xz
dev-python/python-oembed: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/python-oembed/python-oembed-0.2.4.ebuild')
-rw-r--r--dev-python/python-oembed/python-oembed-0.2.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-oembed/python-oembed-0.2.4.ebuild b/dev-python/python-oembed/python-oembed-0.2.4.ebuild
new file mode 100644
index 00000000000..510d26a8480
--- /dev/null
+++ b/dev-python/python-oembed/python-oembed-0.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library that implements an OEmbed consumer"
+HOMEPAGE="https://pypi.python.org/pypi/python-oembed"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed"
+}