summaryrefslogtreecommitdiff
path: root/dev-python/python-stdnum/python-stdnum-1.7.ebuild
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2017-10-08 18:39:14 +0200
committerCédric Krier <cedk@gentoo.org>2017-10-08 18:39:14 +0200
commite92182740e9619d12c44b85b26e3263b24cf10c2 (patch)
treec47889f49c04c8dc69d014c8038d8dc3e0a9d3b8 /dev-python/python-stdnum/python-stdnum-1.7.ebuild
parent221a1cb362185611f3219611b0e31ee60fc9301a (diff)
downloadgentoo-e92182740e9619d12c44b85b26e3263b24cf10c2.tar.gz
gentoo-e92182740e9619d12c44b85b26e3263b24cf10c2.tar.xz
dev-python/python-stdnum: Version bumps
Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'dev-python/python-stdnum/python-stdnum-1.7.ebuild')
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/python-stdnum-1.7.ebuild b/dev-python/python-stdnum/python-stdnum-1.7.ebuild
new file mode 100644
index 00000000000..6bb1b062dfb
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="http://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies test"
+
+RDEPEND="vies? ( dev-python/suds )"
+DEPEND="${DEPEND}
+ dev-python/setuptools
+ test? ( dev-python/nose )"
+
+DOCS=( ChangeLog NEWS README )
+
+python_test() {
+ nosetests || die
+}