summaryrefslogtreecommitdiff
path: root/dev-python/python-uinput
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-uinput
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-uinput')
-rw-r--r--dev-python/python-uinput/Manifest3
-rw-r--r--dev-python/python-uinput/metadata.xml8
-rw-r--r--dev-python/python-uinput/python-uinput-0.10.1.ebuild29
-rw-r--r--dev-python/python-uinput/python-uinput-0.10.2.ebuild26
-rw-r--r--dev-python/python-uinput/python-uinput-0.9.ebuild29
5 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/python-uinput/Manifest b/dev-python/python-uinput/Manifest
new file mode 100644
index 00000000000..be646df2322
--- /dev/null
+++ b/dev-python/python-uinput/Manifest
@@ -0,0 +1,3 @@
+DIST python-uinput-0.10.1.tar.gz 21549 SHA256 bf11ba44850f56142de1f4ac883322ad4f5b14d8c149c01f90e9d96f8ada9c9f SHA512 ec1767fc40071d299ca5955163a0ee1ad9ff896d462037c305f4fdfb6b05be4b360699b1a966a40571c742ac5699c0468c2537787483fa6fe1a0cc19e533ee5a WHIRLPOOL 6c083b28e48093df85e0648e3756abf7a02f55daa89dee9dd7bd629b9d6a81c9bd4e8129e682a856a7bc7fae8ea0f05ed8ebfa279e0d843d44e9e6729f4a64f2
+DIST python-uinput-0.10.2.tar.gz 21736 SHA256 913ca8e37dd9e9948d2e81803791ff8b90837230eae3b8563c9d7390bc6315dc SHA512 0009e3c3f82c5a5da61e9adf17d77a2efb9223f02324a4f7c7033b165d5e4e395566c34ccb11ef54cc4ce1623b1432a144614cbae7a88e9c06824b15ef00e1b7 WHIRLPOOL f850346138e59dcbda897e49efbabc77d60ef174fb24e1e62007d47afcb3b0d8a14023255fc74326843f08b2afdce8dd259e44318b73aa194c3a859d78753c65
+DIST python-uinput-0.9.tar.gz 18260 SHA256 2cd5ea90bf83bc3ce56e3d2897de9133080e940f1396551d21305aac43611295 SHA512 bd31b963ce1134670d2b49d243f0613d32355c41c511a13b9963ecca531806d9fa41c8b6cc10717bda16328cdd6b8ab175202dfa774b55372d81f21aba692e65 WHIRLPOOL 25f99d22a8f47217878f28a9357cd3e679c050e165cd8a1c965181559114567df6e8a1059098d0141a3328dd03fe078368b74fe632257512c77f1765853f581e
diff --git a/dev-python/python-uinput/metadata.xml b/dev-python/python-uinput/metadata.xml
new file mode 100644
index 00000000000..61e16744278
--- /dev/null
+++ b/dev-python/python-uinput/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">python-uinput</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-uinput/python-uinput-0.10.1.ebuild b/dev-python/python-uinput/python-uinput-0.10.1.ebuild
new file mode 100644
index 00000000000..65b2c5829b4
--- /dev/null
+++ b/dev-python/python-uinput/python-uinput-0.10.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic API to the Linux uinput kernel module"
+HOMEPAGE="http://tjjr.fi/sw/python-uinput/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/udev"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed \
+ -e "s:libudev.so.0:libudev.so:g" \
+ -i setup.py || die
+ rm libsuinput/src/libudev.h || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/python-uinput/python-uinput-0.10.2.ebuild b/dev-python/python-uinput/python-uinput-0.10.2.ebuild
new file mode 100644
index 00000000000..39bbbc72507
--- /dev/null
+++ b/dev-python/python-uinput/python-uinput-0.10.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic API to the Linux uinput kernel module"
+HOMEPAGE="http://tjjr.fi/sw/python-uinput/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/udev"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ rm libsuinput/src/libudev.h || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/python-uinput/python-uinput-0.9.ebuild b/dev-python/python-uinput/python-uinput-0.9.ebuild
new file mode 100644
index 00000000000..992ab615051
--- /dev/null
+++ b/dev-python/python-uinput/python-uinput-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic API to the Linux uinput kernel module"
+HOMEPAGE="http://tjjr.fi/sw/python-uinput/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="virtual/udev"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ fix_missing_newlines() {
+ sed -r -i 's/\)([A-Z]+)/\)\n\1/g' "${BUILD_DIR}"/lib/uinput/ev.py || die "sed failed"
+ }
+ python_foreach_impl fix_missing_newlines
+ distutils-r1_src_install
+}