summaryrefslogtreecommitdiff
path: root/dev-python/python-xlib/python-xlib-0.17.ebuild
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2016-10-07 15:24:35 +0900
committerPatrice Clement <monsieurp@gentoo.org>2016-10-10 09:39:11 +0200
commit309031fc6ffddceee447ce194bddcbe032e67acd (patch)
tree92d3ec8425d27d4993b4480b6b31d561afc62bed /dev-python/python-xlib/python-xlib-0.17.ebuild
parent53bd2f7ea658aa2f6c20ebe854d2bd0c374608ed (diff)
downloadgentoo-309031fc6ffddceee447ce194bddcbe032e67acd.tar.gz
gentoo-309031fc6ffddceee447ce194bddcbe032e67acd.tar.xz
dev-python/python-xlib: version bump to 0.17.
- Project has moved to GitHub: https://github.com/python-xlib/python-xlib - Support for Python 3 (3.3, 3.4 and 3.5) has been added. Gentoo-Bug: https://bugs.gentoo.org/591292 Package-Manager: portage-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/2502 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/python-xlib/python-xlib-0.17.ebuild')
-rw-r--r--dev-python/python-xlib/python-xlib-0.17.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/python-xlib/python-xlib-0.17.ebuild b/dev-python/python-xlib/python-xlib-0.17.ebuild
new file mode 100644
index 00000000000..2213985741f
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="https://github.com/python-xlib/python-xlib"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+# DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ sed -e 's:make:$(MAKE):g' -i doc/Makefile || die
+ cp -r "${FILESDIR}"/defs doc/src/ || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ cd doc || die
+ VARTEXFONTS="${T}"/fonts emake html
+ fi
+}
+
+python_test() {
+ cd test || die
+
+ local t
+ for t in *.py; do
+ "${EPYTHON}" "${t}" || die
+ done
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}