summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-27 16:27:05 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-28 09:46:52 +0100
commitda701dae27112514bae3afc4285ed60be0a3c3e6 (patch)
treeedb816e5bbc0690ebc8fb9bdbe347eb45d44910d /dev-python/pyzmq
parentfe349ba006d0bbbebceb193900c2f07571cc7692 (diff)
downloadgentoo-da701dae27112514bae3afc4285ed60be0a3c3e6.tar.gz
gentoo-da701dae27112514bae3afc4285ed60be0a3c3e6.tar.xz
dev-python/pyzmq: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-15.1.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index e7d6e428342..4a4bde6c2cd 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -2,3 +2,4 @@ DIST pyzmq-14.4.1.tar.gz 995366 SHA256 cb4a59875fdc26315045d800bac008b8e10a4cf2d
DIST pyzmq-14.6.0.tar.gz 1001020 SHA256 7746806ff94f1e8c1e843644c6bbd3b9aaeb1203c2eaf38879adc23dbd5c35bb SHA512 02e7feaca0ed73d48af2577fa9fc240e947bf9cea444b3819b8fd39fc2ca4b50c8f11ff27c8477386ef7bee1e8f5bbca50769403ab1393d43624065e647b6544 WHIRLPOOL e10c96a8852cd57dc7ec622405925c987a66cfecff125b6b664a8ab48078b6bea59749421122b7158ace0f366c6d61eb617e9b2f7e951000c9a61d86b87a2ff0
DIST pyzmq-14.7.0.tar.gz 1048389 SHA256 77994f80360488e7153e64e5959dc5471531d1648e3a4bff14a714d074a38cc2 SHA512 22c30414c99bddb71f47b37f49f19b0cb1a535bdc6835fac13c78d030a59ed362124393acd41b7e04bb1f8ca231cabb49d010ac93142786ec35ee4a303f168ed WHIRLPOOL 82f1940133d23bc11acaaf66a92cebfdc76f844f990f90314198b3a65b2dd561e2ab7a5b532f76e6a9a6dd93520b7ae096331fb09eb302b898616e916d35e702
DIST pyzmq-15.0.0.tar.gz 1069616 SHA256 376ca24cf365092d03bd1de00ed4319910aef84394cb4805a866bdf0b6d317bb SHA512 7d42e6e2218ff9668db92cc68ea511a90bac4a4f950ca42d199b82cf17dee587c824be16ea0e315da7b482e7ced0d97769cc500bf9d0fa2eb8a5b7c764c8305f WHIRLPOOL b615493aafd93a529b5b1af2ee161fa6f34c5efd47ee592d0ed4e1d6bc9d4b9b14206450278d2781bf3c688853629822c944ac58cce4d10d0a9a4a6f01b72437
+DIST pyzmq-15.1.0.tar.gz 1072983 SHA256 bd5b279998538bb197baf59c81584550d713b1b17761e8a638bb6fbda9e5d08d SHA512 776ee7e45df29af3fecc4b8037cc04e62fc745ca7f7ce3f84a4419a2ed1571e87de290c7d2fdc58d869e3ef60454dd5eedc78f46f757d5da87e8ece4bb96c9a7 WHIRLPOOL f3926b3ef80109a3e7dfabd2ab861cf4800238e9c0cbd2f1aef9242e3c299aaa3df28d037d97610a308da3b27719e4f5a661bd68c0a82e122c7fd64871543d16
diff --git a/dev-python/pyzmq/pyzmq-15.1.0.ebuild b/dev-python/pyzmq/pyzmq-15.1.0.ebuild
new file mode 100644
index 00000000000..fa6baca8e0a
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-15.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="http://www.zeromq.org/bindings:python https://pypi.python.org/pypi/pyzmq"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+PY2_USEDEP=$(python_gen_usedep python2_7)
+RDEPEND="
+ >=net-libs/zeromq-4.1.2:=
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/cffi:=[${PYTHON_USEDEP}]
+ dev-python/gevent[${PY2_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ doc? (
+ >=dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ tc-export CC
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ # suite reports error in absence of gevent under py3 but is designed to continue
+ # rather than exit making py3 apt for the test phase
+ nosetests -svw "${BUILD_DIR}/lib/" || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}