summaryrefslogtreecommitdiff
path: root/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2017-01-22 15:12:24 +0100
committerJohann Schmitz <ercpe@gentoo.org>2017-01-22 15:12:48 +0100
commitd385283ef7727ab1065aa25505ccb4dff58ae9e7 (patch)
tree91e7d8bd6ce97d014fe9de2e730943ed9fefebfb /dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
parent2b28fbb27e1dec410a4a6ea0711df851d3d07086 (diff)
downloadgentoo-d385283ef7727ab1065aa25505ccb4dff58ae9e7.tar.gz
gentoo-d385283ef7727ab1065aa25505ccb4dff58ae9e7.tar.xz
dev-python/requests-oauthlib: Version bump
Package-Manager: Portage-2.3.0, Repoman-2.3.1
Diffstat (limited to 'dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild')
-rw-r--r--dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
new file mode 100644
index 00000000000..9bbf4a50360
--- /dev/null
+++ b/dev-python/requests-oauthlib/requests-oauthlib-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="https://github.com/requests/requests-oauthlib"
+SRC_URI="https://github.com/requests/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]"
+
+#Refrain from a doc build for now
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_test() {
+ esetup.py test
+}