summaryrefslogtreecommitdiff
path: root/dev-python/rfc3986
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/rfc3986
parent150a8c1ca0830ab41b9a33075f8eac102cfe9421 (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.xz
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/rfc3986')
-rw-r--r--dev-python/rfc3986/Manifest1
-rw-r--r--dev-python/rfc3986/rfc3986-0.4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rfc3986/Manifest b/dev-python/rfc3986/Manifest
index ed2ac9af66f..0757c2593fa 100644
--- a/dev-python/rfc3986/Manifest
+++ b/dev-python/rfc3986/Manifest
@@ -1 +1,2 @@
DIST rfc3986-0.3.1.tar.gz 21591 SHA256 b94638db542896ccf89dc62785ec26dbcbd6a97d337f64e02615b164b974f2e5 SHA512 47c0cff5b67de5cc54ce3a24eb6d192a8b1414f5bb25e54056561fc0394058ec94853e62b9495dd72e15074921b66153279d4dffd1c199e252d569646a34aaed WHIRLPOOL b2ae2145dd078dfed954eda8e76d41a5776a6760e21d247d50bb06a10400785b5fd78f77e6b01b4de75a076ede123ae501db800458dc0e7fa822d90d7983c229
+DIST rfc3986-0.4.1.tar.gz 22354 SHA256 5ac85eb132fae7bbd811fa48d11984ae3104be30d44d397a351d004c633a68d2 SHA512 a4731206a4179d3970fcf9c21405f7e9686268ef3610ab5ca2413a867d83b83188c0efd5958b0b4ba8fc4076da9bc0cf18aef774213a1b58fc42bfc8a6d5dd92 WHIRLPOOL 9e26818343bc2d174cdb3737902b0edc5c3911c9e2aee7e3a7bf7d40eaa7920345a2103d8f9ec6a8f432d54f856cd37c7fbd9c53da12678fce3e3cecd682186a
diff --git a/dev-python/rfc3986/rfc3986-0.4.1.ebuild b/dev-python/rfc3986/rfc3986-0.4.1.ebuild
new file mode 100644
index 00000000000..d8f53ea9249
--- /dev/null
+++ b/dev-python/rfc3986/rfc3986-0.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Validating URI References per RFC 3986"
+HOMEPAGE="http://tools.ietf.org/html/rfc3986 https://github.com/sigmavirus24/rfc3986 https://rfc3986.rtfd.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND=""
+
+python_test() {
+ py.test -vv || die
+}