summaryrefslogtreecommitdiff
path: root/dev-python/ropemacs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ropemacs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ropemacs')
-rw-r--r--dev-python/ropemacs/Manifest2
-rw-r--r--dev-python/ropemacs/metadata.xml9
-rw-r--r--dev-python/ropemacs/ropemacs-0.7.ebuild32
-rw-r--r--dev-python/ropemacs/ropemacs-0.8.ebuild32
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/ropemacs/Manifest b/dev-python/ropemacs/Manifest
new file mode 100644
index 00000000000..6004dbe3780
--- /dev/null
+++ b/dev-python/ropemacs/Manifest
@@ -0,0 +1,2 @@
+DIST ropemacs-0.7.tar.gz 20744 SHA256 12d7dc9872f20de757610224999e866aac89ff04864d15a393e937965b70b8f4 SHA512 3cc61fe6416a473430ace720caf5516def0166752c8e2d72398e6bb863ee0c40a4b818a2754c60824bd365f20e9f72e5967f0d9ee7fce8851a2f753618c790c5 WHIRLPOOL f3111adc8caa4262379c34add573ccfa46f142c19aea5956219d94600e20985832d1b65cfdd66683b13063ac82885a9d97fb983cffc699d3155900e3727c0fd8
+DIST ropemacs-0.8.tar.gz 22161 SHA256 e1ae9691d402eaa525f56d37f5fefff8b8fe9892188e49600d01063a5acb535f SHA512 3e42ce03758c13d8f6e66b69a4b9ab7620956ed0272ecf770c0cea204ffae8c85f41103b29e507db7d68d6dc006b14e6ca5ce31d8ca17b6a66bf743f1110a9b3 WHIRLPOOL 5632799ace9e3c0a40342b3d7be5da3f5763a290931a84fa464bed214cd18c2968b58ee209868e2977524b3cf9bce48fb32f0aeab0897ad9df1cac80e81f838b
diff --git a/dev-python/ropemacs/metadata.xml b/dev-python/ropemacs/metadata.xml
new file mode 100644
index 00000000000..0cd4d5bd166
--- /dev/null
+++ b/dev-python/ropemacs/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>emacs</herd>
+ <upstream>
+ <remote-id type="pypi">ropemacs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ropemacs/ropemacs-0.7.ebuild b/dev-python/ropemacs/ropemacs-0.7.ebuild
new file mode 100644
index 00000000000..5940aba3934
--- /dev/null
+++ b/dev-python/ropemacs/ropemacs-0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils readme.gentoo
+
+DESCRIPTION="Rope in Emacs"
+HOMEPAGE="http://rope.sourceforge.net/ropemacs.html
+ http://pypi.python.org/pypi/ropemacs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1+" # GPL without version
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/rope[${PYTHON_USEDEP}]
+ dev-python/ropemode[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( README.txt CONTRIBUTORS docs/ropemacs.txt docs/todo.txt )
+
+src_install() {
+ distutils-r1_src_install
+ DOC_CONTENTS="In order to enable ropemacs support in Emacs, install
+ app-emacs/pymacs and add the following line to your ~/.emacs file:
+ \\n\\t(pymacs-load \"ropemacs\" \"rope-\")"
+ readme.gentoo_create_doc
+}
diff --git a/dev-python/ropemacs/ropemacs-0.8.ebuild b/dev-python/ropemacs/ropemacs-0.8.ebuild
new file mode 100644
index 00000000000..c4fc0748031
--- /dev/null
+++ b/dev-python/ropemacs/ropemacs-0.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils readme.gentoo
+
+DESCRIPTION="Rope in Emacs"
+HOMEPAGE="http://rope.sourceforge.net/ropemacs.html
+ http://pypi.python.org/pypi/ropemacs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1+" # GPL without version
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/rope[${PYTHON_USEDEP}]
+ dev-python/ropemode[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local DOCS="${DOCS} README.rst docs/*.rst"
+ distutils-r1_src_install
+
+ DOC_CONTENTS="In order to enable ropemacs support in Emacs, install
+ app-emacs/pymacs and add the following line to your ~/.emacs file:
+ \\n\\t(pymacs-load \"ropemacs\" \"rope-\")"
+ readme.gentoo_create_doc
+}