summaryrefslogtreecommitdiff
path: root/dev-python/rtslib-fb
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-30 18:43:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-30 21:12:13 -0500
commitb54a183dd82914e18bd3ddaae8605e029c4ad14d (patch)
tree41edd0e616280b03be74d6e95c057720ae2678d9 /dev-python/rtslib-fb
parent99223088f75196bb9182299927492daf5bcaaf5b (diff)
downloadgentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.gz
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.xz
openstack p2, newton is done, will add heat later
Diffstat (limited to 'dev-python/rtslib-fb')
-rw-r--r--dev-python/rtslib-fb/Manifest1
-rw-r--r--dev-python/rtslib-fb/rtslib-fb-2.1.58.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/rtslib-fb/Manifest b/dev-python/rtslib-fb/Manifest
index ba95a1c2626..93ba2e8934d 100644
--- a/dev-python/rtslib-fb/Manifest
+++ b/dev-python/rtslib-fb/Manifest
@@ -1 +1,2 @@
DIST rtslib-fb-2.1.57.tar.gz 30746 SHA256 bca0fb05e3d96fdfc8495a6b1e82d6ff92190c610863c2ec6400bfcf3120361c SHA512 0b46b17498bf2a5f4853c9d989bf6a192280d95416b195c0c9eaede4759612b6c3800fb1d3f44979c10e95ba0c3f06dd9756a805d63f61b292a611003f48059b WHIRLPOOL b707f5f4978dced01e5a92a2f709010925cdfa3ee0485f7bc677ad81df6f0fc177f03ee075763e159990e4f7fbf60ab51c030d309cb2e2bc329f9557b6658145
+DIST rtslib-fb-2.1.58.tar.gz 30706 SHA256 5806f9903557907787abd9c8b9dffb2b312e6c5e3ff40d50d26b10c37b118d47 SHA512 a3f4c22d42b4b76bb9a5ce2d1027c4964385fa427ec55cb92f1acb0f9b647fc0788307354144534e3f216fc12f3fc1a0a55fd4454225324aa13488f21df092c5 WHIRLPOOL 0c773035c7e8502550f2835ae92ed3a31a2bb05661b12c6e4fe59a0f7065a3dc2d08962af69a7e5f07f4a0a4736d5d9e9204c47b6af6e478500c435d642d8324
diff --git a/dev-python/rtslib-fb/rtslib-fb-2.1.58.ebuild b/dev-python/rtslib-fb/rtslib-fb-2.1.58.ebuild
new file mode 100644
index 00000000000..c3038c1adb7
--- /dev/null
+++ b/dev-python/rtslib-fb/rtslib-fb-2.1.58.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python object API for managing the Linux LIO kernel target"
+HOMEPAGE="https://github.com/agrover/rtslib-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/rtslib[${PYTHON_USEDEP}]"
+RDEPEND="!dev-python/rtslib[${PYTHON_USEDEP}]"