summaryrefslogtreecommitdiff
path: root/dev-python/ryu
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-30 18:43:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-30 21:12:13 -0500
commitb54a183dd82914e18bd3ddaae8605e029c4ad14d (patch)
tree41edd0e616280b03be74d6e95c057720ae2678d9 /dev-python/ryu
parent99223088f75196bb9182299927492daf5bcaaf5b (diff)
downloadgentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.gz
gentoo-b54a183dd82914e18bd3ddaae8605e029c4ad14d.tar.xz
openstack p2, newton is done, will add heat later
Diffstat (limited to 'dev-python/ryu')
-rw-r--r--dev-python/ryu/Manifest1
-rw-r--r--dev-python/ryu/ryu-4.5.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ryu/Manifest b/dev-python/ryu/Manifest
index 9bc61f4e1bd..740b24ea7ec 100644
--- a/dev-python/ryu/Manifest
+++ b/dev-python/ryu/Manifest
@@ -1 +1,2 @@
DIST ryu-4.0.tar.gz 1344663 SHA256 bf6d1ad6977fb0b9ee01567fbb7a4ec28d70d14bff8fe4370b617b1228f1ee12 SHA512 fbc0f3f903098c9682215eb8fb99cedeeb29b2bdec94801c3832bbf90e7beaf7aa7173ccb87959846c4fe23d21a8390b6672817aec2cc6bc75ef20a376944154 WHIRLPOOL 32ed4b2f23b09785c28ad99b45e101750866f48ffc57294683db25af88ab19e63966eb9e6c649d3af1160e8381b785b01a3ed95de24929f45db2124ec9e00e59
+DIST ryu-4.5.tar.gz 1368324 SHA256 ef9ee003e4a3d37222119175d98c64f4684124c2c6cdacb16e67b308cd71e8e8 SHA512 5b109d5e88a6a6384ac59597677978e974e5747d2bd9324cc143ee5e29823a76c2e2d0354024ff6680ff090bff129933d6a3bdc227b82d0b157e1942950e2370 WHIRLPOOL 8918aabdf19f45bf47d7dee53003c2b52fcc596a47183531cff091877fa37f29748a15dcdb783161c5b5fe1f71cb0024a6ee210f54f1fcab0026cadf2a6ad815
diff --git a/dev-python/ryu/ryu-4.5.ebuild b/dev-python/ryu/ryu-4.5.ebuild
new file mode 100644
index 00000000000..48fd9d09173
--- /dev/null
+++ b/dev-python/ryu/ryu-4.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Component-based Software-defined Networking Framework"
+HOMEPAGE="http://osrg.github.io/ryu/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND=""