summaryrefslogtreecommitdiff
path: root/dev-python/schema/schema-0.5.0.ebuild
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-07-06 10:45:35 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-07-06 10:53:25 +0000
commitdd40e012e16f581052aca2580300caeb1b1fb644 (patch)
treeb0cb0afb875e7f4aab4c30ecae5baf9b22f6a3d5 /dev-python/schema/schema-0.5.0.ebuild
parent75e8a84bc6a37d5dc5752e3eac0ca667566d165a (diff)
downloadgentoo-dd40e012e16f581052aca2580300caeb1b1fb644.tar.gz
gentoo-dd40e012e16f581052aca2580300caeb1b1fb644.tar.xz
dev-python/schema: Add the schema library to the tree.
schema is a library for validating Python data structures, such as those obtained from config-files, forms, external services or command-line parsing, converted from JSON/YAML (or something else) to Python data-types. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/schema/schema-0.5.0.ebuild')
-rw-r--r--dev-python/schema/schema-0.5.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/schema/schema-0.5.0.ebuild b/dev-python/schema/schema-0.5.0.ebuild
new file mode 100644
index 00000000000..80c11187a67
--- /dev/null
+++ b/dev-python/schema/schema-0.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.python.org/pypi/schema https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"