summaryrefslogtreecommitdiff
path: root/dev-python/seaborn
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-12-05 12:36:13 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-10 22:55:42 +0100
commite83af315c69252fc0f4614c300003ab776b2dd1a (patch)
treefe94cb97fcd9921d7d7d45dba39f7c3ca39a6548 /dev-python/seaborn
parente8e71d0ca7bde44412858cc98314ddc7de8a8a05 (diff)
downloadgentoo-e83af315c69252fc0f4614c300003ab776b2dd1a.tar.gz
gentoo-e83af315c69252fc0f4614c300003ab776b2dd1a.tar.xz
dev-python/seaborn: version bump.
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/3020
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/Manifest1
-rw-r--r--dev-python/seaborn/seaborn-0.7.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index 1b35895c900..6f494502ac7 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1,3 +1,4 @@
DIST seaborn-0.5.1.tar.gz 104426 SHA256 8c8f7f1036cf6155be3d987ee23d2eeeed8c272b0803b32b7d524614f8526688 SHA512 bbcdf0625e096b8f41d56521f3e319a64d82632131d80ed1e81144362fe881d9b5df4d3b5a5fa09363b1782897d9ac68d3fc647d82da4e0017c5dba21c897b8d WHIRLPOOL 682a32f2d40a742e87659f27a675c437875a4b4dfcfd8195b774c49ae38f5ad73ee4b73aa00dabab33ccb6015e5eb5326605c897c8b1cac341cc9db0d6143f73
DIST seaborn-0.6.0.tar.gz 145188 SHA256 e078399b56ed0d53a4aa8bd4d6bd4a9a9deebc0b4acad259d0ef81830affdb68 SHA512 3b7e7c1b72bd55aba012f312b43920044ea011648b4d855f4acd813ae644a75b4c60aa56c35ea759dcd7683bb6d9ea3b4f1209215950a5014ad46ebe04088fb1 WHIRLPOOL 66c9834f982f4a27c1a884bd4c8f73bb718fe0948bc7b3bde86f7d9bd354bbf783e36c576b8e2b0ded50cdf63244f463b9419e808ab70f6d5c2a24e89c570e99
DIST seaborn-0.7.0.tar.gz 154263 SHA256 15a8b2747becfdb86cfa60b5fcfa9bb934e42ef0ced660e0d57e8aea741f7145 SHA512 475785b074c154e3f2442450c15926dddbbad6a76a808247aeab42eb5f6a0b92b7e2daf032f4adea62d7c9ef3ac3d6eb1bb9aaf35b152ca75faeaedb748e38be WHIRLPOOL bb15397b33487d3ece614ee35a7c7239d3ad616ea4c074f57672637f9193539a7bd923cb23a8c51cc5543bdb80e0e70a8e0bb4c30c69601b58a4f0ed1fc43809
+DIST seaborn-0.7.1.tar.gz 158146 SHA256 fa274344b1ee72f723bab751c40a5c671801d47a29ee9b5e69fcf63a18ce5c5d SHA512 6c730d87a97f0df3b38b78ee9255d47b900aece1308127e2772dc982b19691efe6afe192752c89cba9e9532b567dc1c3c103675e580e6f1151355ea89d1019b3 WHIRLPOOL 072ac50dfd554160b1225f0b901258915feddca91d47fd1c54e6469d9767478cd01b8585e2e236f2c5658dcbee9f6ea6c0b7f3ea0e3e0e41cdfd21343489b077
diff --git a/dev-python/seaborn/seaborn-0.7.1.ebuild b/dev-python/seaborn/seaborn-0.7.1.ebuild
new file mode 100644
index 00000000000..a3ae6e57212
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="http://stanford.edu/~mwaskom/software/seaborn/ https://github.com/mwaskom/seaborn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cat > matplotlibrc <<- EOF
+ backend : Agg
+ EOF
+ virtx nosetests --verbosity=3
+}