summaryrefslogtreecommitdiff
path: root/dev-python/setproctitle
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/setproctitle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/setproctitle')
-rw-r--r--dev-python/setproctitle/Manifest1
-rw-r--r--dev-python/setproctitle/metadata.xml8
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.8.ebuild51
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/setproctitle/Manifest b/dev-python/setproctitle/Manifest
new file mode 100644
index 00000000000..dc79bcb9f0d
--- /dev/null
+++ b/dev-python/setproctitle/Manifest
@@ -0,0 +1 @@
+DIST setproctitle-1.1.8.tar.gz 23208 SHA256 b564cf6488217c7a4632a9fe646fc3a3bea2f9712b4e667e9632b870d1a58211 SHA512 9d0ab8e65afd7e1ac019ea47995498dae1f82d8aebb333dfc4c953e745441cb9a8db942ad8417522d1f9a805bc50ad680f3a37cb4cbbd4214d261d4fed600b20 WHIRLPOOL 4014739eab6ba3d91a15e2c11d9e91ee6a0254a23be1c2f8a7963bc327559a5a7c6197398d6053743a9479562e76873fe47f11a6c810f2c21d3e462440183166
diff --git a/dev-python/setproctitle/metadata.xml b/dev-python/setproctitle/metadata.xml
new file mode 100644
index 00000000000..4f5a535f3b4
--- /dev/null
+++ b/dev-python/setproctitle/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">setproctitle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/setproctitle/setproctitle-1.1.8.ebuild b/dev-python/setproctitle/setproctitle-1.1.8.ebuild
new file mode 100644
index 00000000000..d955b403686
--- /dev/null
+++ b/dev-python/setproctitle/setproctitle-1.1.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="Allow customization of the process title"
+HOMEPAGE="http://code.google.com/p/py-setproctitle/ http://pypi.python.org/pypi/setproctitle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+# on <py2.7 the test suite uses SkipTest from nose,
+# so we need to run it using nose.
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( HISTORY.rst README.rst )
+
+python_prepare_all() {
+ sed -i -e "/pyrun/s:%s'.*):'):" tests/*.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -r -l tests "${BUILD_DIR}"/ || die
+
+ if [[ ${EPYTHON} == python3.* ]]; then
+ # Notes:
+ # -W is not supported by python3.1
+ # -n causes Python to write into hardlinked files
+ 2to3 --no-diffs -w "${BUILD_DIR}"/tests/*.py || die
+ fi
+
+ cd "${BUILD_DIR}" || die
+
+ # prepare embedded executable
+ emake tests/pyrun CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS} $(python-config --cflags)" \
+ LDLIBS="${LDLIBS} $(python-config --libs)"
+
+ nosetests || die "Tests fail with ${EPYTHON}"
+}