summaryrefslogtreecommitdiff
path: root/dev-python/socksipy
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/socksipy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/socksipy')
-rw-r--r--dev-python/socksipy/Manifest2
-rw-r--r--dev-python/socksipy/metadata.xml9
-rw-r--r--dev-python/socksipy/socksipy-1.00.ebuild27
-rw-r--r--dev-python/socksipy/socksipy-1.02.ebuild27
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/socksipy/Manifest b/dev-python/socksipy/Manifest
new file mode 100644
index 00000000000..a90712890de
--- /dev/null
+++ b/dev-python/socksipy/Manifest
@@ -0,0 +1,2 @@
+DIST SocksiPy-branch-1.02.zip 10650 SHA256 6f0fb4224bf2ed48e2302d3fa226bb94ba1d138dfb03aa0ba88747ad8bdfd471 SHA512 6d17de2bbefac123e447d46dae082e46246132e582ab4f129661c0bfb090df3acf0ee0ea074a80882b835c4fa5346808e530da0170ecf01b610ce6f799aa6234 WHIRLPOOL c98290445311efafa145efd89a16ea2401a20bf3c1bf6a70cd4a245b5ba17ba2b53efcb5e3ec92a7689f08bd03c559218fc7e5afb67f509642f6bf1299e8a46a
+DIST socksipy-1.00.tar.gz 7627 SHA256 4a7dc98f5a39b797e4bbb3db13747954836a3ac94c29880849538effdbce0639 SHA512 21d28ccd0616bf0cef1aa2260e32e5862dfcdd7d2dc83448aa58948144af0134d8371fafea5644d983b2b49d5cce3df6606d77126941b8f36f53be74d6fab479 WHIRLPOOL 31f40e4a8bd3cef0eff80d7061e91e5fb6951cce4ab6f1bb1541542668915ac1e8ce6ddb384c66608d6ddccd3983fd53fb35eed0f034b961665fa8b95ed84703
diff --git a/dev-python/socksipy/metadata.xml b/dev-python/socksipy/metadata.xml
new file mode 100644
index 00000000000..9e396139c96
--- /dev/null
+++ b/dev-python/socksipy/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/socksipy/socksipy-1.00.ebuild b/dev-python/socksipy/socksipy-1.00.ebuild
new file mode 100644
index 00000000000..df8b15cfae4
--- /dev/null
+++ b/dev-python/socksipy/socksipy-1.00.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="SOCKS proxy implementation for python"
+HOMEPAGE="http://socksipy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/SocksiPy%20${PV}/SocksiPy.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ python_foreach_impl python_domodule socks.py
+}
diff --git a/dev-python/socksipy/socksipy-1.02.ebuild b/dev-python/socksipy/socksipy-1.02.ebuild
new file mode 100644
index 00000000000..bf01e3ce468
--- /dev/null
+++ b/dev-python/socksipy/socksipy-1.02.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="SocksiPy-branch"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="SOCKS proxy implementation for python"
+HOMEPAGE="http://socksipy.sourceforge.net/ http://code.google.com/p/socksipy-branch/"
+SRC_URI="http://socksipy-branch.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( BUGS README )