summaryrefslogtreecommitdiff
path: root/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-01 22:33:20 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:24 +0000
commit4e3d9058aee41f2c9fda216affb6fa14ac717bcc (patch)
tree83fa4118e1413d549bf25c99ced94037fe9a2e10 /dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild
parenta4353af258867b8765d2d8061086a038c89d3490 (diff)
downloadgentoo-4e3d9058aee41f2c9fda216affb6fa14ac717bcc.tar.gz
gentoo-4e3d9058aee41f2c9fda216affb6fa14ac717bcc.tar.xz
dev-python/sphinxcontrib-googleanalytics: fix for bug #623852 and add sphinxcontrib namespace dependency
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild')
-rw-r--r--dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild
new file mode 100644
index 00000000000..ab505c55c22
--- /dev/null
+++ b/dev-python/sphinxcontrib-googleanalytics/sphinxcontrib-googleanalytics-0.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension googleanalytics"
+HOMEPAGE="https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/setup.py.utf-8.patch" )
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}