summaryrefslogtreecommitdiff
path: root/dev-python/tinydb
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-14 18:11:33 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-14 18:54:21 +0100
commita93bdc7519ddb798f707026ad962ca3aee7db4ea (patch)
treee184cf2b7d9243d848bc7691af94c7277575651f /dev-python/tinydb
parent5ee2e23d3231c441049f5c2759b4a17c172aa48d (diff)
downloadgentoo-a93bdc7519ddb798f707026ad962ca3aee7db4ea.tar.gz
gentoo-a93bdc7519ddb798f707026ad962ca3aee7db4ea.tar.xz
dev-python/tinydb: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/tinydb')
-rw-r--r--dev-python/tinydb/Manifest1
-rw-r--r--dev-python/tinydb/tinydb-3.1.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tinydb/Manifest b/dev-python/tinydb/Manifest
index 69c520b0baa..57b553c1295 100644
--- a/dev-python/tinydb/Manifest
+++ b/dev-python/tinydb/Manifest
@@ -1 +1,2 @@
DIST tinydb-3.1.2.zip 33703 SHA256 6d9df6c30fc37dad487c23bfadfa6161de422a7f2b16b55d779df88559fc9095 SHA512 5878c783ebcc413e08cf106e356258853b2a0d593e1ef6f5a35bdd1e85e7cb092289b745d9fab7aa2d95d66f131409193bdcd19b93506079610d55f1d288070d WHIRLPOOL 976804530eb5188a43f756f697e9d78f019d8b1ebe99e79c2172c4a5c9675f47e415c5feefa994e7134f3ddc3c3b59cafdf0dc548299dbe4095b852a1a0f270a
+DIST tinydb-3.1.3.zip 33969 SHA256 c46d46e5e4e632df47c75d8bf402f3d8e08a468e782b5475398dc6ac6448e16d SHA512 451f942f1fa38bf159cabc5b0738cb818921bf47a2159211a4048eee91a23dd734bcf3883e62d7b4ff85fa68def78edadf05d845a0ad0f3936d281e91de65ee6 WHIRLPOOL 0adf66a74359d5c99d263c9b6f2418539dc762eeed28993935e9c99a04058dbfdf5c85c73c8643d9b366982b438066fbb2c405723dc01673d103197a3e386817
diff --git a/dev-python/tinydb/tinydb-3.1.3.ebuild b/dev-python/tinydb/tinydb-3.1.3.ebuild
new file mode 100644
index 00000000000..0520012dcb4
--- /dev/null
+++ b/dev-python/tinydb/tinydb-3.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tiny, document oriented database optimized for your happiness :)"
+HOMEPAGE="https://github.com/msiemens/tinydb http://pypi.python.org/pypi/tinydb"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed \
+ -e "s:find_packages():find_packages(exclude=['tests']):g" \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v -v || die
+}