summaryrefslogtreecommitdiff
path: root/dev-python/tqdm
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-08-29 17:07:11 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-01 23:29:07 +0200
commita414f97b75127221a2c91a155ff7fc9fdae03be9 (patch)
tree788cd55dfb22bde2c99937caef01e75ee82ca98e /dev-python/tqdm
parent0c72fb7f752e9411ef03f48bd64daad849e68d82 (diff)
downloadgentoo-a414f97b75127221a2c91a155ff7fc9fdae03be9.tar.gz
gentoo-a414f97b75127221a2c91a155ff7fc9fdae03be9.tar.xz
dev-python/tqdm: new ebuild
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2159 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/metadata.xml19
-rw-r--r--dev-python/tqdm/tqdm-0_pre20140115.ebuild23
-rw-r--r--dev-python/tqdm/tqdm-9999.ebuild22
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
new file mode 100644
index 00000000000..8c05471e1c7
--- /dev/null
+++ b/dev-python/tqdm/Manifest
@@ -0,0 +1 @@
+DIST tqdm-0_pre20140115.tar.gz 3073 SHA256 4caed4edc4fab72972cc2f71611abbb1595ef817752d74ffdd787ed6d75467a9 SHA512 62cb08418bec6f231022f806f54b8c4d9bdc56c23eb9e446e221f9a45aa568e72cfa99f13e811b9ac570c46baac22e7801cbbe9ef0a5aff264332b04768083f5 WHIRLPOOL b4fe6a5b524611a1c7b1126eedd2186c13e9f7b15a3e653f5fe2be0b768462752bf155cb254a3d6bf3b776ef4d01132e1abd011c151c652f794cca8452ad64ce
diff --git a/dev-python/tqdm/metadata.xml b/dev-python/tqdm/metadata.xml
new file mode 100644
index 00000000000..125d0096670
--- /dev/null
+++ b/dev-python/tqdm/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Instantly make your loops show a progress meter - just wrap
+ any iterator with "tqdm(iterator)", and you're done!
+ </longdescription>
+ <upstream>
+ <remote-id type="github">noamraph/tqdm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/tqdm/tqdm-0_pre20140115.ebuild b/dev-python/tqdm/tqdm-0_pre20140115.ebuild
new file mode 100644
index 00000000000..e60bec19cbf
--- /dev/null
+++ b/dev-python/tqdm/tqdm-0_pre20140115.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Add a progress meter to your loops in a second."
+HOMEPAGE="https://github.com/noamraph/tqdm"
+COMMIT="da5fdbf7c05a9127f04ac5887292457e8335f480"
+SRC_URI="https://github.com/noamraph/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
diff --git a/dev-python/tqdm/tqdm-9999.ebuild b/dev-python/tqdm/tqdm-9999.ebuild
new file mode 100644
index 00000000000..98fb54f7bb0
--- /dev/null
+++ b/dev-python/tqdm/tqdm-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Add a progress meter to your loops in a second."
+HOMEPAGE="https://github.com/noamraph/tqdm"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/noamraph/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""