summaryrefslogtreecommitdiff
path: root/dev-python/treq
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/treq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/treq')
-rw-r--r--dev-python/treq/Manifest1
-rw-r--r--dev-python/treq/metadata.xml12
-rw-r--r--dev-python/treq/treq-0.2.1.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/treq/Manifest b/dev-python/treq/Manifest
new file mode 100644
index 00000000000..b8a8dc8871f
--- /dev/null
+++ b/dev-python/treq/Manifest
@@ -0,0 +1 @@
+DIST treq-0.2.1.tar.gz 30954 SHA256 487b9a48f15c1bc482b9be694ad436d70ecdc7a9f0fd3aaf02a30b7f547d9b9d SHA512 d9236c395dca66d358fc9bb1b752e02a7d6335195235808452542de33145057c1c2e959658015b3c89c9a20c35b1a8edb752e151230e72edd313dde6cd6a4cac WHIRLPOOL 2d9b4d5bbf6c8a274d43be6c92f26b4158cd4844074f84d5cd1ef09f49e3ee41454b1b7874074ec3a8c8617a299ddf6d8df6a12d41cd660a188811ae92a44573
diff --git a/dev-python/treq/metadata.xml b/dev-python/treq/metadata.xml
new file mode 100644
index 00000000000..061624702a4
--- /dev/null
+++ b/dev-python/treq/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ryao@gentoo.org</email>
+ <name>Richard Yao</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">treq</remote-id>
+ <remote-id type="github">dreid/treq</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/treq/treq-0.2.1.ebuild b/dev-python/treq/treq-0.2.1.ebuild
new file mode 100644
index 00000000000..78bb1bca8f6
--- /dev/null
+++ b/dev-python/treq/treq-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="Python requests like API built on top of Twisted's HTTP client."
+HOMEPAGE="https://github.com/dreid/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+COMMON_DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${COMMON_DEPEND}
+ >=dev-python/pyopenssl-0.11[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-12.1.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-web-12.1.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]"
+
+DEPEND="${COMMON_DEPEND}
+ doc? ( dev-python/sphinx
+ ${RDEPEND} )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C "${S}/docs" html
+}
+
+python_install_all() {
+ use doc && dohtml -r "${S}/docs/_build/html/"*
+}
+
+python_test() {
+ trial treq || die "Tests fail with ${EPYTHON}"
+}