summaryrefslogtreecommitdiff
path: root/dev-python/vertex/vertex-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-18 21:42:35 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-18 21:43:53 +0100
commit6b0d191daaaf407191798c7a95486dc15fe7b9c5 (patch)
tree440526d1aaff9b3a764bbd4444dea70d1abcb478 /dev-python/vertex/vertex-0.3.1-r1.ebuild
parent954ba3c866b9e9a91509970553b9c397ecbd0c2e (diff)
downloadgentoo-6b0d191daaaf407191798c7a95486dc15fe7b9c5.tar.gz
gentoo-6b0d191daaaf407191798c7a95486dc15fe7b9c5.tar.xz
dev-python/vertex: Fix test deps
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-python/vertex/vertex-0.3.1-r1.ebuild')
-rw-r--r--dev-python/vertex/vertex-0.3.1-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/vertex/vertex-0.3.1-r1.ebuild b/dev-python/vertex/vertex-0.3.1-r1.ebuild
index c790604505c..6fa2fd97364 100644
--- a/dev-python/vertex/vertex-0.3.1-r1.ebuild
+++ b/dev-python/vertex/vertex-0.3.1-r1.ebuild
@@ -12,15 +12,16 @@ HOMEPAGE="http://divmod.org/trac/wiki/DivmodVertex https://pypi.python.org/pypi/
SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
KEYWORDS="~amd64 ~x86"
-IUSE="libressl"
+IUSE="libressl test"
-DEPEND="
+RDEPEND="
!libressl? ( dev-libs/openssl:0 )
libressl? ( dev-libs/libressl )
>=dev-python/epsilon-0.6.0-r1[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13-r1[${PYTHON_USEDEP}]
dev-python/twisted-core[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pretend )"
python_install_all() {
distutils-r1_python_install_all