summaryrefslogtreecommitdiff
path: root/dev-python/xlrd/xlrd-1.0.0.ebuild
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-02-28 21:22:35 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-02-28 21:28:26 +0000
commit16f389305f999456697aee776e455f65beebf52a (patch)
treeb50953dad76553d565c84a8d7d585a06bd152095 /dev-python/xlrd/xlrd-1.0.0.ebuild
parent78a79c5f110c8df3dcf4b2e0fe68441d832c53be (diff)
downloadgentoo-16f389305f999456697aee776e455f65beebf52a.tar.gz
gentoo-16f389305f999456697aee776e455f65beebf52a.tar.xz
dev-python/xlrd: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/xlrd/xlrd-1.0.0.ebuild')
-rw-r--r--dev-python/xlrd/xlrd-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/xlrd/xlrd-1.0.0.ebuild b/dev-python/xlrd/xlrd-1.0.0.ebuild
new file mode 100644
index 00000000000..c6449ad6314
--- /dev/null
+++ b/dev-python/xlrd/xlrd-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to extract data from Microsoft Excel spreadsheets"
+HOMEPAGE="http://www.python-excel.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+python_prepare_all() {
+ # Remove this if examples get reintroduced
+ sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
+}