summaryrefslogtreecommitdiff
path: root/dev-python/xlwt
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-12-11 08:36:10 +0100
committerJustin Lecher <jlec@gentoo.org>2016-12-11 10:14:37 +0100
commit79ec80943cce8beda947db67e16bc5f407151d54 (patch)
tree751a0d5a7318f171b153d2a44bd6dd6b2fbbef65 /dev-python/xlwt
parent61f1b8f504017b81cb914746f73bd1bb0b612bec (diff)
downloadgentoo-79ec80943cce8beda947db67e16bc5f407151d54.tar.gz
gentoo-79ec80943cce8beda947db67e16bc5f407151d54.tar.xz
dev-python/xlwt: Version Bump
Package-Manager: portage-2.3.3 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/xlwt')
-rw-r--r--dev-python/xlwt/Manifest1
-rw-r--r--dev-python/xlwt/xlwt-1.1.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/xlwt/Manifest b/dev-python/xlwt/Manifest
index 846ec8b8ca8..1603162c675 100644
--- a/dev-python/xlwt/Manifest
+++ b/dev-python/xlwt/Manifest
@@ -1,2 +1,3 @@
DIST xlwt-0.7.5.tar.gz 115100 SHA256 9478bd70b86590b9ac2697967c8a10a4917d900636349ca73eeb362a3227423c SHA512 d385c36c80002998891dd93d4ebcdd962239463ee089965961d3b8955d4783bbcdec96920891a252ee6cb076eab6b13ffad83e7758c179dcbc684e82fa8dfe35 WHIRLPOOL 46d01a1bcfc5f01585082bf3ff8750cecd7ce87b5ebe279a3d9377c8c7e272f070cb28d430285c900d0e2389469097088b6126932c76f3778b274b86696f6adc
DIST xlwt-1.0.0.tar.gz 129588 SHA256 ac432939eec8daa9f88af994ff53f009e607a4e1102772ec0be0b2a86b2c1cf9 SHA512 45788a506635f1ef6380d46aa0af724e511e401e8347dcf48dbf4e2d90e7f4c7f66838cd9616cf58807ffb939daba1f47b0d2cf449f8cb528db41fba84cc8866 WHIRLPOOL d3d344faae89fad012f05fe5b19e5ce16dd144016abf7ea15123a9725c77a732e85d93131c692dbcaf306cdc8d1b06efcaf39227265c612200107d2c20541132
+DIST xlwt-1.1.2.tar.gz 153374 SHA256 aed648c17731f40f84550dd2a1aaa53569f0cbcaf5610ba895cd2632587b723c SHA512 dfe27e1415bd9ebe83b41f45fe8f08396269d4075014bacb7e59384aa8bea0e5479e0a4874fc727ab00c8c8ee44a17f9af8736f78a30db76b7330e79a1942cc3 WHIRLPOOL b44468558b39d3819a75ab1c6b9db8a66fd6fd8e1bfe9bd23661788dc77796bf3788405d386ff191f27b10b361757a5bfc94e8bb4f895bdc85bc18fb9350a5a4
diff --git a/dev-python/xlwt/xlwt-1.1.2.ebuild b/dev-python/xlwt/xlwt-1.1.2.ebuild
new file mode 100644
index 00000000000..c7e944b1e63
--- /dev/null
+++ b/dev-python/xlwt/xlwt-1.1.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
+HOMEPAGE="https://pypi.python.org/pypi/xlwt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# Prevent d'loading in the doc build
+PATCHES=( "${FILESDIR}"/docbuild.patch )
+
+python_prepare_all() {
+ # Don't install documentation and examples in site-packages directories.
+ sed -e "/package_data/d" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests || die "tests failed under ${EPYTHON}}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}