summaryrefslogtreecommitdiff
path: root/dev-python/zc-buildout
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/zc-buildout
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/zc-buildout')
-rw-r--r--dev-python/zc-buildout/Manifest1
-rw-r--r--dev-python/zc-buildout/metadata.xml23
-rw-r--r--dev-python/zc-buildout/zc-buildout-2.3.1.ebuild34
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/zc-buildout/Manifest b/dev-python/zc-buildout/Manifest
new file mode 100644
index 00000000000..983f9ccaca5
--- /dev/null
+++ b/dev-python/zc-buildout/Manifest
@@ -0,0 +1 @@
+DIST zc.buildout-2.3.1.tar.gz 292209 SHA256 3295b8944c637f65db3d6c2ded239b7b41a7f2df0e0bceb8b092247edf1866fb SHA512 cb741f02ccb119349e9e734667a64bec3248bbddc58a0e3d9ba10b1d2459e084170713be24051a529996fbc641ca8162d86c1c3ad3efdb2a95d2dd705616b73d WHIRLPOOL c391a6c62b72ce4bd56d12616df8580ab6c247e9bef74cf198bb777846ce7a450a31b7bd2088271d9a3faabd4b0388fb8e5b432b4c0f15e5b921c95c7e33e298
diff --git a/dev-python/zc-buildout/metadata.xml b/dev-python/zc-buildout/metadata.xml
new file mode 100644
index 00000000000..cca1f992b28
--- /dev/null
+++ b/dev-python/zc-buildout/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>tupone@gentoo.org</email>
+ <name>Alfredo Tupone</name>
+ </maintainer>
+ <longdescription lang="en">Buildout is a system for managing development buildouts. While often identified as a Zope project,
+and indeed licensed under the ZPL by Zope creator Jim Fulton, buildout is useful for configurations
+beyond Zope, and even, in rare cases, a few that have nothing to do with Python.
+The Buildout project provides support for creating applications, especially Python applications. It
+provides tools for assembling applications from multiple parts, Python or otherwise. An application
+may actually contain multiple programs, processes, and configuration settings.
+The word .buildout. refers to a description of a set of parts and the software to create and assemble
+them. It is often used informally to refer to an installed system based on a buildout definition. For
+example, if we are creating an application named .Foo., then .the Foo buildout. is the collection of
+configuration and application-specific software that allows an instance of the application to be
+created. We may refer to such an instance of the application informally as .a Foo buildout..</longdescription>
+ <upstream>
+ <remote-id type="pypi">zc.buildout</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zc-buildout/zc-buildout-2.3.1.ebuild b/dev-python/zc-buildout/zc-buildout-2.3.1.ebuild
new file mode 100644
index 00000000000..38a148cfd4a
--- /dev/null
+++ b/dev-python/zc-buildout/zc-buildout-2.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="System for managing development buildouts"
+HOMEPAGE="http://pypi.python.org/pypi/zc.buildout"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( README.rst doc/tutorial.txt )
+# Tests require zope packages absent from portage
+
+# Prevent incorrect installation of data file
+python_prepare_all() {
+ sed -e '/^ include_package_data/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}