summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 20:24:34 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 20:49:13 +0200
commit06fc005cccb4ae258d5b6b0d2183b8446c66cdb6 (patch)
tree6dd5da48b67f32e69ee033d17469396351d669ce /dev-python
parent641226130f6ee8b1e390db562276c6f9045193ea (diff)
downloadgentoo-06fc005cccb4ae258d5b6b0d2183b8446c66cdb6.tar.gz
gentoo-06fc005cccb4ae258d5b6b0d2183b8446c66cdb6.tar.xz
dev-python/pytest-timeout: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 7717c07d851..115d29cd99c 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1 +1,2 @@
DIST pytest-timeout-0.4.tar.gz 10204 SHA256 d5900aaa94af5cb2d06ed806b1e636255e65a8a26eccecccd2b9a9d6123d50d5 SHA512 07031d64012e683064cd0bf2cef1d7209f02085e07dd8c7dfc704270d1e6ecf9679c639d529586c7d52d9425244a05ac362a7cd0092ca1f162a54539f58286e4 WHIRLPOOL b4befc271e378246d3e9fdd23a931fa400a981f79e90b0d44bbd533bea2be976fb4fcf73f6aa552d129e6945d82880bdf7bbf08c653c787913a8b782be54ab51
+DIST pytest-timeout-1.0.0.tar.gz 11125 SHA256 1465096be73e16df1e15d1b1453692428a7e15b997d756bc565aee0d12798ce1 SHA512 67a42562dfa7175c213ae50a7e152f04406f01a4821d69c9e95637a06a2574de8ce2f147030ff1417cc99eb7d518d7c59ac72ff2671dc3e7e813962da91e7591 WHIRLPOOL cc5f915b9a875d2c5886d6eee1329deb5c86e853cf65f3964364278ad6f6271cf05fbbe37960d14019d99dced0bfd5c84726f692c43930e51331b2e750604cba
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.0.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.0.0.ebuild
new file mode 100644
index 00000000000..10fb5310285
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to abort hanging tests"
+HOMEPAGE="https://pypi.python.org/pypi/pytest-timeout"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ ${EPYTHON} test_pytest_timeout.py || die
+}