summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-07-08 16:44:53 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-07-08 17:52:03 +0000
commit1d63b7c6b5d8d73a3b78ae2cc76c3a55c15d11d9 (patch)
treee098e704008736273cbc25a276da4b44510ffe96 /dev-python
parent16c6579daa190223ff44787904e5346180787ce9 (diff)
downloadgentoo-1d63b7c6b5d8d73a3b78ae2cc76c3a55c15d11d9.tar.gz
gentoo-1d63b7c6b5d8d73a3b78ae2cc76c3a55c15d11d9.tar.xz
dev-python/libzilla: Add libzilla ebuild to the tree.
libzilla is a library for managing Bugzilla bug reports from the CLI. Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/libzilla/Manifest1
-rw-r--r--dev-python/libzilla/libzilla-1.0.ebuild23
-rw-r--r--dev-python/libzilla/metadata.xml14
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/libzilla/Manifest b/dev-python/libzilla/Manifest
new file mode 100644
index 00000000000..149d687b338
--- /dev/null
+++ b/dev-python/libzilla/Manifest
@@ -0,0 +1 @@
+DIST libzilla-1.0.zip 15189 SHA256 b73f6b5c66bfdca021d84939f064649feec6feba6691511945289891d690e5be SHA512 1ce8d6c473b172ad742f175ec2d588e5a35770033a92ad24823a2163e097f0d86482b84b20b698c2c6c6b3b6338b3b274272ec0f798d18cd107889cfae51d4a4 WHIRLPOOL 00addbd40e3d5b5a4c3fa726465307d8b6bf3dd8c105c764e5f9ada79944e1f05b56a38ab8ebd9de24cd88e61e0d55aaaf1589ebcc1dec5b29219eb55ba62d58
diff --git a/dev-python/libzilla/libzilla-1.0.ebuild b/dev-python/libzilla/libzilla-1.0.ebuild
new file mode 100644
index 00000000000..a83eb4c9a77
--- /dev/null
+++ b/dev-python/libzilla/libzilla-1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for managing Bugzilla bug reports from the CLI"
+HOMEPAGE="https://github.com/monsieurp/libzilla"
+SRC_URI="https://github.com/monsieurp/libzilla/archive/v${PV}.zip -> ${P}.zip"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]"
diff --git a/dev-python/libzilla/metadata.xml b/dev-python/libzilla/metadata.xml
new file mode 100644
index 00000000000..5e1aebe4f3b
--- /dev/null
+++ b/dev-python/libzilla/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">monsieurp/libzilla</remote-id>
+ </upstream>
+</pkgmetadata>