summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2017-05-23 11:47:56 +0200
committerSlawomir Lis <slis@gentoo.org>2017-05-23 12:37:42 +0200
commit5ee976ed93b4c306dd0d2ab987f6afbd7a1b9948 (patch)
tree0d4016c6d6df7a68024972adb19227750692bac7 /dev-python
parentcde2393d61994b1a5964e1df1e5d79208438e379 (diff)
downloadgentoo-5ee976ed93b4c306dd0d2ab987f6afbd7a1b9948.tar.gz
gentoo-5ee976ed93b4c306dd0d2ab987f6afbd7a1b9948.tar.xz
dev-python/djangocms-picture: version bump to 2.0.5
Also updated to use PYTHON_USEDEP as in bug 618924 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/djangocms-picture/Manifest1
-rw-r--r--dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/djangocms-picture/Manifest b/dev-python/djangocms-picture/Manifest
index 4696e0a4e05..18cebdb40cb 100644
--- a/dev-python/djangocms-picture/Manifest
+++ b/dev-python/djangocms-picture/Manifest
@@ -1,3 +1,4 @@
DIST djangocms-picture-0.1.tar.gz 33969 SHA256 c9d553c712a062bb8997a2862f8349c545a481ee5bdbde16b8c7cbf35026cbd3 SHA512 ea925d873d32e2a1fdb789bf51758c3d7dacd295bbe217be4fb490b3cd26e452c17895c52713f6405edba83e6dead68596ed5c19d5bca22dff5f762e175e490c WHIRLPOOL 1a1feb08c3f5fda9a3775df4839335be1960a9bcf70ff75b79923197b9b6e09075a9744de9ec474bf1a74ab81e02e602b624728b0598089021857fb7a0cf55bc
DIST djangocms-picture-1.0.0.tar.gz 35127 SHA256 38b40f36362114aa8978864c5c9afd13aa904c0d2f92f7a86f22b766ddf2d9ac SHA512 863c7f6d542b5a847627f509e61be90f192fa619d56aac08fa7c6bf1c462124d598d99915834ac746f08b0250477ca6cca69bde6bafb7169aced98757b2e838c WHIRLPOOL e923581fbd0c38cdec771a1fa45730ac0e735bd574166008a5e58197cb37a73bb9c6fb7ed35c4f8ff6fe55bb81bb07eb3f568ff7a85d462e931c3e19a59ec421
DIST djangocms-picture-2.0.3.tar.gz 24484 SHA256 1378c5a0b145e5878515c604bef1ca6912c360a287f0743497c68a45d561847c SHA512 b8e4ebb152c0d4d1e61b575655b40cc2b567b1acb4a4853205e471b38800f645d0e18c7039f305f34d93b47f9053ab649f259d0fb96d292f4e7d1a152d5941e9 WHIRLPOOL 2cc03db9ad5c548aaf62dd2cfc30d91a5390fdfdaf07a77668495dbf8b376efcb7bd4a1c07f1a995165c9a9d5519fab5f7cb2672d017013de2d285e2ff8765fe
+DIST djangocms-picture-2.0.5.tar.gz 32329 SHA256 8d890452dd2fdfbcc3d1601411deea6664b01ec870c2791d39d2b1d27db740c7 SHA512 df4ba02d06966d7cee38254baadea5eeb5197557cbda1e8a202e45420881b6216efcc49fa8a6e9f9af30507a93ee2f7110e14e5ae3a645b889c990dfaca3a499 WHIRLPOOL 228022352e3ec8486fcb2cce07130169586f5f92cdc2f7c2221f2fa5d798c72d85ea96a1ce728802b29643409091016e24a1851dcadd728672b0bf17c7b4be9e
diff --git a/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild b/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild
new file mode 100644
index 00000000000..7c68b9e97d2
--- /dev/null
+++ b/dev-python/djangocms-picture/djangocms-picture-2.0.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Picture plugin for django CMS"
+HOMEPAGE="https://pypi.python.org/pypi/djangocms-picture"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/djangocms-attributes-field-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/django-filer-1.2.4[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+PDEPEND=">=dev-python/django-cms-3.2.0"
+
+src_prepare() {
+ sed -i 's/find_packages()/find_packages(exclude=["tests"])/g' "${S}/setup.py"
+ eapply_user
+}