summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-06-09 16:12:46 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-06-09 17:23:27 +0000
commit63ac55e0f89cd9e634fe37e96176045bed11be29 (patch)
tree97b883f1b1f5ba77911fd4a534400694b32c2256 /dev-python
parent2c0315b22e91780e1eb3cd9f19d465d6a1f8c2f0 (diff)
downloadgentoo-63ac55e0f89cd9e634fe37e96176045bed11be29.tar.gz
gentoo-63ac55e0f89cd9e634fe37e96176045bed11be29.tar.xz
dev-python/astropy: force numpy-1.10
Fixing (maybe): Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=585468 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/astropy/Manifest2
-rw-r--r--dev-python/astropy/astropy-1.0.6.ebuild89
-rw-r--r--dev-python/astropy/astropy-1.1.1.ebuild96
-rw-r--r--dev-python/astropy/astropy-1.1.2.ebuild2
-rw-r--r--dev-python/astropy/files/astropy-1.0.4-disable_helper.patch14
-rw-r--r--dev-python/astropy/files/astropy-1.0.4-system-pytest.patch14
-rw-r--r--dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch15
7 files changed, 1 insertions, 231 deletions
diff --git a/dev-python/astropy/Manifest b/dev-python/astropy/Manifest
index 3d686040965..2f4f81ffa28 100644
--- a/dev-python/astropy/Manifest
+++ b/dev-python/astropy/Manifest
@@ -1,3 +1 @@
-DIST astropy-1.0.6.tar.gz 7632331 SHA256 1a0190ad420323b9bd8f7b29995a39580d7d59c5329c825bb5abb52e2f7b936d SHA512 84e02204bc55d3bd6e0e891dc56ab218d1deb65882d5d771b3f80c2a11790f77c103b0c0d5537f1842d98f0d3ded19039c82482c15147edadac89e9707537b40 WHIRLPOOL b20e5c2e3677485eaf22c71c7e3461443d4a92bf7b0e649f5e0153e0b1d46741958e983b743aa30bf07ad971a0c865e53211963653ddf814a5d4362f36f07b02
-DIST astropy-1.1.1.tar.gz 8157305 SHA256 4d2e7a8bd5191a66d7e1a52beefb4a0b6f496a1e9e8212422613219cb514769f SHA512 bc3c370da32d5f0098dbfc2808dba9d4d4424d3dcfba4d7ffd84b39569387b79ad93086e10678c259237f9cfe1229725501d0dc4eba51c9d01a4cd8a72024fb4 WHIRLPOOL 5b40955f56e6f080ad93b224eabd345565ef9f5e7f5ccb00e2737bd714117bc9b35922a044fe4ccaddb9d30fa72e13dd560577392120bfbd0a9d10c8aaa5aa01
DIST astropy-1.1.2.tar.gz 8059713 SHA256 6f0d84cd7dfb304bb437dda666406a1d42208c16204043bc920308ff8ffdfad1 SHA512 b83c4a1415a3eb8c016507705d0d2f22971e4da937bb97953eec08f8f856933d8fa76ce8c536122235b19e7879b16add2e20fd2fee3e488f9b2b4bf1b9f4dbdb WHIRLPOOL 01cdfd33c29f7128e88be3f53b7ecdec37d95ba06acae6ceeba83746e0454aa220396fb00519b30639ac01b5b297fad004488d34856295735e04924d154c4eb9
diff --git a/dev-python/astropy/astropy-1.0.6.ebuild b/dev-python/astropy/astropy-1.0.6.ebuild
deleted file mode 100644
index b5ae9cda304..00000000000
--- a/dev-python/astropy/astropy-1.0.6.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Core functionality for performing astrophysics with Python"
-HOMEPAGE="http://astropy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-libs/expat-2.1.0:0=
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-astronomy/erfa-1.2:0=
- >=sci-astronomy/wcslib-4.25:0=
- >=sci-libs/cfitsio-3.350:0=
- sys-libs/zlib:0="
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- media-gfx/graphviz
- )
- test? (
- dev-libs/libxml2[${PYTHON_USEDEP}]
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.4-disable_helper.patch"
- "${FILESDIR}/${PN}-1.0.4-system-six.patch"
- "${FILESDIR}/${PN}-1.0.4-system-pytest.patch"
- "${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
- )
-
-python_prepare_all() {
- export mydistutilsargs="--offline"
- rm -r ${PN}_helpers || die
- cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
- rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
- #rm -rvf ${PN}/extern/* || die
- #{configobj,{six,pytest,configobj}.py} || die
-
- cat >> setup.cfg <<-EOF
-
- [build]
- use_system_libraries=1
- EOF
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- python_export_best
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/astropy/astropy-1.1.1.ebuild b/dev-python/astropy/astropy-1.1.1.ebuild
deleted file mode 100644
index a006013a162..00000000000
--- a/dev-python/astropy/astropy-1.1.1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Core functionality for performing astrophysics with Python"
-HOMEPAGE="http://astropy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-libs/expat-2.1.0:0=
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-astronomy/erfa-1.2:0=
- >=sci-astronomy/wcslib-5:0=
- >=sci-libs/cfitsio-3.360:0=
- sys-libs/zlib:0="
-DEPEND="${RDEPEND}
- >=dev-python/astropy-helpers-1.1[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? (
- $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-libs/libxml2[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/h5py[${PYTHON_USEDEP}]' python2_7)
- media-gfx/graphviz
- $(python_gen_cond_dep 'sci-libs/scipy[${PYTHON_USEDEP}]'python2_7)
- )
- test? (
- dev-libs/libxml2[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.4-system-six.patch"
- "${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
- "${FILESDIR}/${PN}-1.1.1-fix-wcs.patch"
- "${FILESDIR}/${PN}-1.1.1-mark-kown-failures.patch"
-)
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_prepare_all() {
- export mydistutilsargs="--offline"
- export ASTROPY_USE_SYSTEM_PYTEST=True
- rm -r ${PN}_helpers || die
- cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
- rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
- sed -i -e '/auto_use/s/True/False/' setup.cfg || die
- cat >> setup.cfg <<-EOF
- [build]
- use_system_libraries=1
- EOF
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- python_setup "python2*"
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/astropy/astropy-1.1.2.ebuild b/dev-python/astropy/astropy-1.1.2.ebuild
index c3bd9617fbb..c8b61aea91c 100644
--- a/dev-python/astropy/astropy-1.1.2.ebuild
+++ b/dev-python/astropy/astropy-1.1.2.ebuild
@@ -20,7 +20,7 @@ IUSE="doc test"
RDEPEND="
>=dev-libs/expat-2.1.0:0=
dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.10[${PYTHON_USEDEP}]
dev-python/ply[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
>=sci-astronomy/erfa-1.2:0=
diff --git a/dev-python/astropy/files/astropy-1.0.4-disable_helper.patch b/dev-python/astropy/files/astropy-1.0.4-disable_helper.patch
deleted file mode 100644
index 2e751c9ee5d..00000000000
--- a/dev-python/astropy/files/astropy-1.0.4-disable_helper.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Author: Ole Streicher <olebole@debian.org>
-Description: Disable astropy-helpers copy
-Bug: https://bugs.debian.org/761055
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -22,7 +22,7 @@
- bitmap = static/wininst_background.bmp
-
- [ah_bootstrap]
--auto_use = True
-+auto_use = False
-
- [pep8]
- # E101 - mix of tabs and spaces
diff --git a/dev-python/astropy/files/astropy-1.0.4-system-pytest.patch b/dev-python/astropy/files/astropy-1.0.4-system-pytest.patch
deleted file mode 100644
index 638f7e84bb0..00000000000
--- a/dev-python/astropy/files/astropy-1.0.4-system-pytest.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -ur astropy-1.0/astropy/tests/helper.py astropy-1.0.pytest/astropy/tests/helper.py
---- astropy-1.0/astropy/tests/helper.py 2015-02-18 22:45:32.000000000 +0100
-+++ astropy-1.0.pytest/astropy/tests/helper.py 2015-02-19 16:20:28.201778929 +0100
-@@ -35,8 +35,8 @@
- AstropyDeprecationWarning,
- AstropyPendingDeprecationWarning)
- from ..config import configuration
--
--if os.environ.get('ASTROPY_USE_SYSTEM_PYTEST') or '_pytest' in sys.modules:
-+# Modified by Fedora package
-+if True or os.environ.get('ASTROPY_USE_SYSTEM_PYTEST') or '_pytest' in sys.modules:
- import pytest
-
- else:
diff --git a/dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch b/dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch
deleted file mode 100644
index efb12737c19..00000000000
--- a/dev-python/astropy/files/astropy-1.1.1-fix-wcs.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Author: Kacper Kowalik <xarthisius.kk@gmail.com>
-Description: Copy keys to a list, since orignal map is modified
-Url: https://github.com/astropy/astropy/issues/4477
-Bug: https://github.com/astropy/astropy/issues/4460
---- a/astropy/wcs/wcs.py
-+++ b/astropy/wcs/wcs.py
-@@ -988,7 +988,7 @@
- """
- # Never pass SIP coefficients to wcslib
- # CTYPE must be passed with -SIP to wcslib
-- for key in (m.group() for m in map(SIP_KW.match, header.keys())
-+ for key in (m.group() for m in map(SIP_KW.match, list(header))
- if m is not None):
- del header[key]
-