summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-09 09:16:41 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-10 19:36:01 +0200
commit66a09c4218f9fb06a480e777d26dd2d82a716662 (patch)
tree05570ee1737829eb68a88c4e571ef7c277a24f77 /dev-python
parent6a8bb90a83e0af7fd9011ea1f9f52282b6d775c9 (diff)
downloadgentoo-66a09c4218f9fb06a480e777d26dd2d82a716662.tar.gz
gentoo-66a09c4218f9fb06a480e777d26dd2d82a716662.tar.xz
dev-python/llvmlite: Update/fix flag mangling
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/llvmlite/llvmlite-0.16.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/llvmlite/llvmlite-0.16.0.ebuild b/dev-python/llvmlite/llvmlite-0.16.0.ebuild
index e470147f80f..47ce82f4870 100644
--- a/dev-python/llvmlite/llvmlite-0.16.0.ebuild
+++ b/dev-python/llvmlite/llvmlite-0.16.0.ebuild
@@ -30,7 +30,11 @@ PATCHES=(
)
python_prepare_all() {
- sed -e 's/-flto$/-flto -fPIC/' \
+ # remove -static-libstdc++, it makes no sense with shared LLVM
+ # add -fPIC, needed to link against shared libraries
+ # disable -flto, we do not force it against user's wishes
+ sed -e 's/-static-libstdc++/-fPIC/' \
+ -e '/^(CXX|LD)_FLTO_FLAGS/d' \
-i ffi/Makefile.linux || die
distutils-r1_python_prepare_all
}