summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-12-08 12:27:15 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-11 02:05:02 +0100
commitda1a22d0d32697a9fcfbcbc733af7a702f930868 (patch)
tree831384b5e4b5fbb540cedd08f25882cf1ca6ebf0 /dev-python
parent0388169771ce315c51065c3bf60ded259870d983 (diff)
downloadgentoo-da1a22d0d32697a9fcfbcbc733af7a702f930868.tar.gz
gentoo-da1a22d0d32697a9fcfbcbc733af7a702f930868.tar.xz
dev-python/pyftpdlib: bump to 1.5.1, drop amd64-fbsd, fix deps, add py3.5
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/3057
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyftpdlib/Manifest1
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index a058caa8f9d..93f906faaa7 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1 +1,2 @@
DIST pyftpdlib-1.4.0.tar.gz 116280 SHA256 5fdd1492efe478f4c354f7d65d9308359751c8fb1d0376466b74a76721c5fcf3 SHA512 61cf28d72a3a99bdc9bddcf434275e4edaeff60bf6481c1e854d81a4ea23ae97b73c8da9d0629a705a003ae8a941c529f9b9ed7cfa25759bd5cd6517f9958ff9 WHIRLPOOL 676f58061e07aa8a9dcce9c7076962875866cebca8eacdd624053cab32de3a7bdb0b17337105839b6c997bf2b4263e759c962362930afddaedc1e9a151b855fa
+DIST pyftpdlib-1.5.1.tar.gz 127582 SHA256 7bcd7fc825123414a157718c6dcdcb0978208d3c865d4650564acef4acce3354 SHA512 81bb634aef7190d97b5939b998c8dd8caf1ce77c2ca66d085826880590a03e7fe4aeefb5eb67f30f25b984962eaae740c4c8c1d5900909029702e37c36bb2b9b WHIRLPOOL 2b878db9386d3fc81d0e2749facfa4183704f705afb677fdae0031a721a050d246eda80fb8eb7dfb7b5369269f57b7995f201d07f1b54e133e2e7d85277d0615
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.1.ebuild
new file mode 100644
index 00000000000..bfd017b30d9
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="https://github.com/giampaolo/pyftpdlib https://pypi.python.org/pypi/pyftpdlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="examples ssl test"
+
+RDEPEND="ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ "${EPYTHON}" ${PN}/test/runner.py || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] && \
+ [[ ${PYTHON_TARGETS} == *python2_7* ]] && \
+ ! has_version dev-python/pysendfile ; then
+ elog "dev-python/pysendfile is not installed"
+ elog "It can considerably speed up file transfers for Python 2"
+ fi
+}