summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-10-22 20:27:56 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-10-22 20:27:56 -0500
commite4810615f173a7d7e82fa3c78a5c3cd0ce4f9913 (patch)
tree8163514b048e2ac690cdae96c3474b99d95a4c5c /dev-python
parent23e2baefa268a263c319287ccd6c4a8924d6b249 (diff)
downloadgentoo-e4810615f173a7d7e82fa3c78a5c3cd0ce4f9913.tar.gz
gentoo-e4810615f173a7d7e82fa3c78a5c3cd0ce4f9913.tar.xz
dev-python/aiohttp: add version 1.0.5
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-1.0.5.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index be3f75eaa8f..7615755d792 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -3,3 +3,4 @@ DIST aiohttp-1.0.1.tar.gz 498972 SHA256 f5133431d66ef8838f40d233b0fc9e4b9e696165
DIST aiohttp-1.0.2.tar.gz 499266 SHA256 d104a8e762debc1acc3fe40dbc4f0da4cace5a797a93d59c618673b390d3947c SHA512 94004219b8809bad26df4119512faaad7ebbc7c961fea2488f333aa580a24691752154a688e9fe224be6aeb2b769c6f101a288fec66fdf66e619756ebe98258b WHIRLPOOL 7130e1ea90ef64af9bd128ae8c021e5ba2061c02b276aa81db0aabd326572ef3e68396c842cedec43d0f68ea33bce6128d3f2275909fdae3a942de90b7d3bfda
DIST aiohttp-1.0.3.tar.gz 499693 SHA256 5ec0fdf17868bcabfef4effa3ce53c4cfa6108b481585bda88498f46435d5eaa SHA512 1fd915d04bf978826863c06a3a9ef5c23fd11c3b6a65b71828a7be4301e24421483717af6181319ba8461a22351decda4fb776765d18843e4ab1f436f5319d73 WHIRLPOOL 8e6b2503833c98d0d5e341275cc82a0a943e3f69b8b2a0c478c826775aff35b343af6d786b919d75f46a920e09b33eca3d24ba1bec316db82d16a1006cd71e0c
DIST aiohttp-1.0.4.tar.gz 562803 SHA256 7e2d4282b2031ca2aaef35d4291743f37a8840821e8b3c6b491fcd903ad853c0 SHA512 437bed5e5f8729e8809411213cdb8f6a7de08879841c0cc89e88eec6de1883702903ecfb1b8e32ecf3701415fd6757545a0aafd44738681050425d5df44bef56 WHIRLPOOL 4ccb55b93fba2774ea65adcf3b5b00c3bc8bc72f05ac2a07bc84d50dbf07c34b4f3ee75265b800ef59aa9c7deb61e23c7662b3226f8aa0c40918c17295085568
+DIST aiohttp-1.0.5.tar.gz 563623 SHA256 053a16d03672cb3055cfac06650d238f55205702207be4a3b40c42333df0ebeb SHA512 f6fe77729a54d817046f0cc952d8906524c2dfe6712dd1972d696680fe34310b6dba9a3b48b6e27c52d3fedd3fa0f541a7c1ac45488b3358e39e3768a01749d9 WHIRLPOOL 51c609bed1bad59e8c1761fa412ed36031da7b80dff03f5edffd84763044cdb570c49d7b9970d133c9b1b224cc293e73004b00447f5b242d91c8286cc21e87c9
diff --git a/dev-python/aiohttp/aiohttp-1.0.5.ebuild b/dev-python/aiohttp/aiohttp-1.0.5.ebuild
new file mode 100644
index 00000000000..b6f53c2eba9
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-1.0.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_4 python3_5 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="https://github.com/KeepSafe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/KeepSafe/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}